summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-06-02 15:49:50 +0300
committerLev Levitsky2016-06-02 15:49:50 +0300
commitcad4d1756ab1e342c5d1fd8c4d48652e66e67c06 (patch)
tree37ab1b549eff71b1f199339d4738d5342bffba71
parentda84be1034c0f12d3dd5f68557b8f62a13634bea (diff)
downloadaur-cad4d1756ab1e342c5d1fd8c4d48652e66e67c06.tar.gz
Version 3.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG38
-rw-r--r--PKGBUILD6
3 files changed, 45 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4497d831250f..b2f72d51171b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Feb 18 15:21:41 UTC 2016
+# Thu Jun 2 12:48:23 UTC 2016
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.2
+ pkgver = 3.3.1
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -16,8 +16,8 @@ pkgbase = python-pyteomics
optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.2.tar.gz
- md5sums = 3fd5bc228d248d085a7bf9a461e5c62c
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.3.1.tar.gz
+ md5sums = 0b81c096944334c53ee52c213a42edee
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 985854c56860..f6c6d142edfc 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,41 @@
+3.3.1
+-----
+
+New submodule :py:mod:`pyteomics.featurexml` with a parser for OpenMS **featureXML** files.
+
+3.3
+---
+
+ - mzML and mzIdentML parsers can now create an index of element offsets.
+ This allows quick random access to elements by unique ID.
+
+ - mzML parsers now come in two flavors: :py:class:`pyteomics.mzml.MzML` and
+ :py:class:`pyteomics.mzml.PreIndexedMzML`. The latter uses the byte offsets
+ listed at the end of the file.
+
+ - New parameters `convert_arrays` and `read_charges` in :py:func:`mgf.read`
+ allow using it without :py:mod:`numpy` and possibly improve performance.
+ The default behavior is retained.
+
+ - Performance optimizations in :py:func:`mgf.read` and :py:func:`parser.cleave`.
+
+ - New decoy generation mode called "fused decoy", described in the paper accepted to JASMS.
+
+API changes
+...........
+
+ - :py:func:`pyteomics.parser.cleave` no longer accepts the `labels` argument.
+ It is emphasized that the input sequences are expected to be in plain one-letter
+ notation, but no checks are performed.
+
+ - :py:func:`DataFrame` functions in :py:mod:`pepxml` and :py:mod:`tandem` now
+ extract more protein-related information. The list-like protein-related values
+ can be reported as lists or packed into strings, depending on the optional
+ paramter `sep`. Some column names have changed as a result.
+
+ - Call signatures of :py:func:`pyteomics.fasta.decoy_sequence` and the functions using it
+ are slightly changed. Standard modes are now also exposed as individual functions.
+
3.2
---
diff --git a/PKGBUILD b/PKGBUILD
index 46c8a9d1c7b1..42e0492ea5c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.2
+pkgver=3.3.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -13,8 +13,8 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-lxml: for XML parsing modules'
'python-numpy: for most of features, highly recommended')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('3fd5bc228d248d085a7bf9a461e5c62c')
+source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
+md5sums=('0b81c096944334c53ee52c213a42edee')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"