summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-02-18 18:22:25 +0300
committerLev Levitsky2016-02-18 18:22:25 +0300
commitda84be1034c0f12d3dd5f68557b8f62a13634bea (patch)
tree65a21ca7e0912a486fd31edec01bcc8732ba47fb
parent15b5333d9710c0080574830d4b1d81f1fa4389c9 (diff)
downloadaur-da84be1034c0f12d3dd5f68557b8f62a13634bea.tar.gz
Version 3.2
-rw-r--r--.SRCINFO13
-rw-r--r--CHANGELOG45
-rw-r--r--PKGBUILD9
3 files changed, 56 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cdabbd9a225..4497d831250f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Feb 18 15:21:41 UTC 2016
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.1.1
+ pkgver = 3.2
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -8,13 +10,14 @@ pkgbase = python-pyteomics
license = Apache
depends = python
depends = python-setuptools
- optdepends = python-matplotlib: for pylab_aux module, optional
+ optdepends = python-matplotlib: for pylab_aux module
+ optdepends = python-sqlalchemy: for mass.unimod module
optdepends = python-pandas: for convenient filtering of CSV tables from search engines
- optdepends = python-lxml: for XML parsing modules, recommended
+ optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.1.1.tar.gz
- md5sums = e367dc7eb11fd7d589183ec7e9b15650
+ source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.2.tar.gz
+ md5sums = 3fd5bc228d248d085a7bf9a461e5c62c
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 94f5eae040c7..985854c56860 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,42 @@
+3.2
+---
+
+New submodule :py:mod:`pyteomics.mass.unimod` contains rewritten machinery
+for handling of Unimod relational databases (contributed by Joshua Klein).
+This is a substitution and extension for the old :py:class:`mass.Unimod` class.
+:py:mod:`pyteomics.mass.unimod` requires SQLAlchemy.
+
+Other changes:
+
+ - New function :py:func:`pyteomics.auxiliary.linear_regression_perpendicular`
+ provides a linear fit minimizing distances from data points to the fit line
+ (as opposed to :py:func:`pyteomics.auxiliary.linear_regression`, which
+ minimizes vertical distances).
+
+ - Both new and old linear regression functions now accept a single array of shape (N, 2).
+
+ - :py:func:`pyteomics.pylab_aux.scatter_trend` now has an optional parameter
+ `regression` which can be a callable performing the regression.
+ Also, the regression equation is now the label of the regression line, not
+ the scatter plot.
+
+ - Another two new parameters for :py:func:`pyteomics.pylab_aux.scatter_trend`
+ are `sigma_kwargs` and `sigma_values`.
+
+ - :py:mod:`pyteomics.pylab_aux` functions :py:func:`plot_line` and
+ :py:func:`scatter_trend` now return the objects they create.
+
+ - Writer functions (:py:func:`pyteomics.mgf.write`, :py:func:`pyteomics.fasta.write`,
+ :py:func:`pyteomics.fasta.write_decoy_db`) now accept a `file_mode` argument that
+ overrides the mode in which the file is opened.
+
+ - In :py:func:`pyteomics.mgf.write` one can now override the format spec for fragment m/z,
+ intensity and charge values using the optinal `fragment_format` argument. Key order and
+ key-value parameter formatters are now also handled via optional arguments.
+
+ - :py:func:`pyteomics.fasta.decoy_db` now supports `ignore_comments` and `parser` arguments.
+
+
3.1.1
-----
@@ -176,8 +215,10 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
-----
- Bugfixes in :py:func:`pyteomics.parser.isoforms`:
- - handling of the `labels` argument is now in accordance with new policy
- - solved memory problems when using `max_mods`
+
+ - handling of the `labels` argument is now in accordance with new policy
+ - solved memory problems when using `max_mods`
+
- :py:func:`pyteomics.parser.cleave` does not require a valid *modX* sequence
by default.
diff --git a/PKGBUILD b/PKGBUILD
index 9d116430e60f..46c8a9d1c7b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.1.1
+pkgver=3.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="http://pythonhosted.org/pyteomics"
license=('Apache')
depends=('python' 'python-setuptools')
-optdepends=('python-matplotlib: for pylab_aux module, optional'
+optdepends=('python-matplotlib: for pylab_aux module'
+ 'python-sqlalchemy: for mass.unimod module'
'python-pandas: for convenient filtering of CSV tables from search engines'
- 'python-lxml: for XML parsing modules, recommended'
+ 'python-lxml: for XML parsing modules'
'python-numpy: for most of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.python.org/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('e367dc7eb11fd7d589183ec7e9b15650')
+md5sums=('3fd5bc228d248d085a7bf9a461e5c62c')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"