summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-04-13 11:04:38 +0800
committerUniversebenzene2022-04-13 11:04:38 +0800
commit1f09eba5f527df648450772b4519aa3044e81b29 (patch)
treeb300e4eba406bc0841c8fc43cd0f0982764add54
parent4fe5e2e84e0ac8f362d8ab90ff489855093f5bbe (diff)
downloadaur-1f09eba5f527df648450772b4519aa3044e81b29.tar.gz
Update to version 0.10.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef27b874c759..6ec510135ea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-pytest-astropy
pkgdesc = Metapackage for all the testing machinery used by the Astropy Project
- pkgver = 0.9.0
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/astropy/pytest-astropy
arch = any
license = BSD
makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
depends = python>=3.7
depends = python-pytest>=4.6
depends = python-pytest-doctestplus>=0.11.0
@@ -14,9 +17,11 @@ pkgbase = python-pytest-astropy
depends = python-pytest-arraydiff>=0.1
depends = python-pytest-astropy-header>=0.1.2
depends = python-pytest-filter-subpackage>=0.1
- depends = python-pytest-cov>=2.0
+ depends = python-pytest-cov>=2.3.1
+ depends = python-pytest-mock>=2.0
+ depends = python-attrs>=19.2.0
depends = python-hypothesis>=5.1
- source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.9.0.tar.gz
- md5sums = 63d99a983d21db297246ae01e83f874b
+ source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.10.0.tar.gz
+ md5sums = 23eafccddbeffaef5c0701e42f8fb048
pkgname = python-pytest-astropy
diff --git a/PKGBUILD b/PKGBUILD
index cdd0f2e0ea35..3c4889036579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,38 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy
_pyname=${pkgname#python-}
-pkgver=0.9.0
+pkgver=0.10.0
pkgrel=1
pkgdesc="Metapackage for all the testing machinery used by the Astropy Project"
arch=('any')
url="https://github.com/astropy/pytest-astropy"
license=('BSD')
-depends=('python>=3.7' 'python-pytest>=4.6' 'python-pytest-doctestplus>=0.11.0' 'python-pytest-remotedata>=0.3.1' 'python-pytest-openfiles>=0.3.1' 'python-pytest-arraydiff>=0.1' 'python-pytest-astropy-header>=0.1.2' 'python-pytest-filter-subpackage>=0.1' 'python-pytest-cov>=2.0' 'python-hypothesis>=5.1')
-makedepends=('python-setuptools-scm')
+depends=('python>=3.7'
+ 'python-pytest>=4.6'
+ 'python-pytest-doctestplus>=0.11.0'
+ 'python-pytest-remotedata>=0.3.1'
+ 'python-pytest-openfiles>=0.3.1'
+ 'python-pytest-arraydiff>=0.1'
+ 'python-pytest-astropy-header>=0.1.2'
+ 'python-pytest-filter-subpackage>=0.1'
+ 'python-pytest-cov>=2.3.1'
+ 'python-pytest-mock>=2.0'
+ 'python-attrs>=19.2.0'
+ 'python-hypothesis>=5.1')
+makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('63d99a983d21db297246ae01e83f874b')
+md5sums=('23eafccddbeffaef5c0701e42f8fb048')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python -m build --wheel --no-isolation
+}
package() {
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}