summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-09-22 16:48:30 +0800
committerUniversebenzene2021-09-22 16:48:30 +0800
commit4fe5e2e84e0ac8f362d8ab90ff489855093f5bbe (patch)
tree213fddffbd9558afce53e5048bbf1429b6b9dfa8
parentf460ebd77a26bc135788985977ce839f1e0d601d (diff)
downloadaur-4fe5e2e84e0ac8f362d8ab90ff489855093f5bbe.tar.gz
Update to version 0.9.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15477a08ea68..ef27b874c759 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-pytest-astropy
pkgdesc = Metapackage for all the testing machinery used by the Astropy Project
- pkgver = 0.8.0
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/astropy/pytest-astropy
- arch = i686
- arch = x86_64
+ arch = any
license = BSD
makedepends = python-setuptools-scm
- depends = python>=3.6
+ depends = python>=3.7
depends = python-pytest>=4.6
- depends = python-pytest-doctestplus>=0.2.0
+ depends = python-pytest-doctestplus>=0.11.0
depends = python-pytest-remotedata>=0.3.1
depends = python-pytest-openfiles>=0.3.1
depends = python-pytest-arraydiff>=0.1
@@ -17,8 +16,7 @@ pkgbase = python-pytest-astropy
depends = python-pytest-filter-subpackage>=0.1
depends = python-pytest-cov>=2.0
depends = python-hypothesis>=5.1
- source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.8.0.tar.gz
- md5sums = 17f45a1a421534216add4941a39ea943
+ source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.9.0.tar.gz
+ md5sums = 63d99a983d21db297246ae01e83f874b
pkgname = python-pytest-astropy
-
diff --git a/PKGBUILD b/PKGBUILD
index 387d571c878d..cdd0f2e0ea35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy
_pyname=${pkgname#python-}
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Metapackage for all the testing machinery used by the Astropy Project"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/astropy/pytest-astropy"
license=('BSD')
-depends=('python>=3.6' 'python-pytest>=4.6' 'python-pytest-doctestplus>=0.2.0' 'python-pytest-remotedata>=0.3.1' 'python-pytest-openfiles>=0.3.1' 'python-pytest-arraydiff>=0.1' 'python-pytest-astropy-header>=0.1.2' 'python-pytest-filter-subpackage>=0.1' 'python-pytest-cov>=2.0' 'python-hypothesis>=5.1')
+depends=('python>=3.7' 'python-pytest>=4.6' 'python-pytest-doctestplus>=0.11.0' 'python-pytest-remotedata>=0.3.1' 'python-pytest-openfiles>=0.3.1' 'python-pytest-arraydiff>=0.1' 'python-pytest-astropy-header>=0.1.2' 'python-pytest-filter-subpackage>=0.1' 'python-pytest-cov>=2.0' 'python-hypothesis>=5.1')
makedepends=('python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('17f45a1a421534216add4941a39ea943')
+md5sums=('63d99a983d21db297246ae01e83f874b')
package() {
cd ${srcdir}/${_pyname}-${pkgver}