summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-07-14 13:40:25 +0800
committerUniversebenzene2019-07-14 13:40:25 +0800
commitf441a198a7fd2291fb21edb32757233ddfb79062 (patch)
tree96ee7758cf304055e3534934456292d7121cbc74
parent0894a39c877defc54cd6b7824ae637b013a7c43c (diff)
downloadaur-f441a198a7fd2291fb21edb32757233ddfb79062.tar.gz
Update to version 0.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD11
3 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33eaf70cc4b3..c7ea7ab703e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Aug 7 04:35:06 UTC 2018
pkgbase = python-pytest-astropy
pkgdesc = Metapackage for all the testing machinery used by the Astropy Project
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/astropy/pytest-astropy
arch = i686
arch = x86_64
@@ -14,8 +12,8 @@ pkgbase = python-pytest-astropy
depends = python-pytest-remotedata>=0.3.0
depends = python-pytest-openfiles>=0.3.0
depends = python-pytest-arraydiff>=0.1
- source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.4.0.tar.gz
- md5sums = d65157ab4b9e37ae01787bb1d4fcebc9
+ source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.5.0.tar.gz
+ md5sums = 35d0393bbe824fe5afbe8cd4a8b5d6e1
pkgname = python-pytest-astropy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df7b618a7b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 03cc65a9b134..549d960a206a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy
-pkgver=0.4.0
-pkgrel=2
+_pyname=${pkgname#python-}
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Metapackage for all the testing machinery used by the Astropy Project"
arch=('i686' 'x86_64')
url="https://github.com/astropy/pytest-astropy"
license=('BSD')
depends=('python-pytest>=3.1.0' 'python-pytest-doctestplus>=0.1.3' 'python-pytest-remotedata>=0.3.0' 'python-pytest-openfiles>=0.3.0' 'python-pytest-arraydiff>=0.1')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-${pkgver}.tar.gz")
-md5sums=('d65157ab4b9e37ae01787bb1d4fcebc9')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('35d0393bbe824fe5afbe8cd4a8b5d6e1')
package() {
- cd ${srcdir}/pytest-astropy-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"