summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-03-11 14:24:31 +0800
committerUniversebenzene2020-03-11 14:24:31 +0800
commitf460ebd77a26bc135788985977ce839f1e0d601d (patch)
treefe97fc76455dfa3b7ca93e44d9f264d3acac7c64
parent54bfd5a2e72da799cc146aea0d122b57e1199686 (diff)
downloadaur-f460ebd77a26bc135788985977ce839f1e0d601d.tar.gz
Update to version 0.8.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
3 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67ffd92dae8c..15477a08ea68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = python-pytest-astropy
pkgdesc = Metapackage for all the testing machinery used by the Astropy Project
- pkgver = 0.7.0
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/astropy/pytest-astropy
arch = i686
arch = x86_64
license = BSD
- makedepends = python-setuptools
- depends = python-pytest>=3.1.0
+ makedepends = python-setuptools-scm
+ depends = python>=3.6
+ depends = python-pytest>=4.6
depends = python-pytest-doctestplus>=0.2.0
depends = python-pytest-remotedata>=0.3.1
depends = python-pytest-openfiles>=0.3.1
depends = python-pytest-arraydiff>=0.1
- depends = python-pytest-astropy-header
- depends = python-hypothesis
- source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.7.0.tar.gz
- md5sums = c76ffcedd809bdc6a9e8559ab80ac475
+ depends = python-pytest-astropy-header>=0.1.2
+ depends = python-pytest-filter-subpackage>=0.1
+ depends = python-pytest-cov>=2.0
+ depends = python-hypothesis>=5.1
+ source = https://files.pythonhosted.org/packages/source/p/pytest-astropy/pytest-astropy-0.8.0.tar.gz
+ md5sums = 17f45a1a421534216add4941a39ea943
pkgname = python-pytest-astropy
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index b3a9799a54ac..387d571c878d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy
_pyname=${pkgname#python-}
-pkgver=0.7.0
+pkgver=0.8.0
pkgrel=1
pkgdesc="Metapackage for all the testing machinery used by the Astropy Project"
arch=('i686' 'x86_64')
url="https://github.com/astropy/pytest-astropy"
license=('BSD')
-depends=('python-pytest>=3.1.0' 'python-pytest-doctestplus>=0.2.0' 'python-pytest-remotedata>=0.3.1' 'python-pytest-openfiles>=0.3.1' 'python-pytest-arraydiff>=0.1' 'python-pytest-astropy-header' 'python-hypothesis')
-makedepends=('python-setuptools')
+depends=('python>=3.6' 'python-pytest>=4.6' 'python-pytest-doctestplus>=0.2.0' 'python-pytest-remotedata>=0.3.1' 'python-pytest-openfiles>=0.3.1' 'python-pytest-arraydiff>=0.1' 'python-pytest-astropy-header>=0.1.2' 'python-pytest-filter-subpackage>=0.1' 'python-pytest-cov>=2.0' 'python-hypothesis>=5.1')
+makedepends=('python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('c76ffcedd809bdc6a9e8559ab80ac475')
+md5sums=('17f45a1a421534216add4941a39ea943')
package() {
cd ${srcdir}/${_pyname}-${pkgver}