summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-12-28 13:05:46 +0800
committerUniversebenzene2021-12-28 13:05:46 +0800
commit0383eb7a40de3fdb130e705dcb2affefa8eeca68 (patch)
treee907a3de66537b8aff54cdba467bb52b544885f3
parentc3b112b67b0c543a865097ec3f48b287dd68f6db (diff)
downloadaur-0383eb7a40de3fdb130e705dcb2affefa8eeca68.tar.gz
Update to version 0.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 33 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 272a2df86b71..6643ccf613a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-pytest-astropy-header
pkgdesc = Pytest plugin to add diagnostic information to the header of the test output
- pkgver = 0.1.2
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/astropy/pytest-astropy-header
- arch = i686
- arch = x86_64
+ arch = any
license = BSD
- makedepends = python-setuptools
- depends = python-pytest>=2.8
- source = https://files.pythonhosted.org/packages/source/p/pytest-astropy-header/pytest-astropy-header-0.1.2.tar.gz
- md5sums = 053712da9315b52dfc7346dc3f5fc312
+ checkdepends = python-numpy
+ makedepends = python-setuptools-scm
+ depends = python-pytest>=4.6
+ source = https://files.pythonhosted.org/packages/source/p/pytest-astropy-header/pytest-astropy-header-0.2.0.tar.gz
+ md5sums = 66eaf720c56fb7b0b0b32308864d1b82
pkgname = python-pytest-astropy-header
-
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 6b0041be2398..144270eb5303 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,36 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-astropy-header
_pyname=${pkgname#python-}
-pkgver=0.1.2
+pkgver=0.2.0
pkgrel=1
pkgdesc="Pytest plugin to add diagnostic information to the header of the test output"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/astropy/pytest-astropy-header"
license=('BSD')
-depends=('python-pytest>=2.8')
-makedepends=('python-setuptools')
+depends=('python-pytest>=4.6')
+makedepends=('python-setuptools-scm')
+checkdepends=('python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('053712da9315b52dfc7346dc3f5fc312')
+md5sums=('66eaf720c56fb7b0b0b32308864d1b82')
+
+prepare() {
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname//-/_}*egg-info \
+ build/lib/${_pyname//-/_}-${pkgver}-py${_pyver}.egg-info
+ PYTHONPATH="build/lib" pytest || warning "Tests failed"
+}
package() {
cd ${srcdir}/${_pyname}-${pkgver}