summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorT.J. Townsend2023-01-22 22:43:46 +0000
committerT.J. Townsend2023-01-22 22:43:46 +0000
commite89e2adefd162849a0b6d293cb4b9cb7cd343916 (patch)
tree162d864d90ecd7e8b242c328703e6fb398647a4b
parent31e8c8c1c805933b645b645076f4dcb4061fc844 (diff)
downloadaur-e89e2adefd162849a0b6d293cb4b9cb7cd343916.tar.gz
remove hardcoded python version strings
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a08294091a5..c24f30a9310b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,8 @@ check() {
cd pytest-black-$pkgver
python setup.py install --root="$PWD/tmp_install" --optimize=1
- PYTHONPATH="$PWD/tmp_install/usr/lib/python3.10/site-packages:$PYTHONPATH:$PWD/tests" py.test
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ PYTHONPATH="$PWD/tmp_install/$site_packages:$PYTHONPATH:$PWD/tests" py.test
}
package() {