summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2020-05-23 22:30:31 -0400
committerredfish2020-05-23 22:30:31 -0400
commit8a97d893bc3a1704c919bbe63f01fa2b17c14ac4 (patch)
tree192da1e287e4cc973179ee5181b68d65882c4277
downloadaur-8a97d893bc3a1704c919bbe63f01fa2b17c14ac4.tar.gz
1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d908cbe014a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pytest-cid
+ pkgdesc = A wrapper around py-cid for writing tests involving CIDs in datastructures.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pytest_cid
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = python-cid
+ source = https://pypi.io/packages/source/p/pytest_cid/pytest_cid-1.0.0.tar.gz
+ sha256sums = 61a1c282220ad1ad419cbfce7c33b3a84781be7a9edae9145da924ab2aaccfe8
+
+pkgname = python-pytest-cid
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1aee993719d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zst
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e927798cbd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-pytest-cid
+_name=pytest_cid
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A wrapper around py-cid for writing tests involving CIDs in datastructures."
+arch=('any')
+url="https://pypi.python.org/pypi/pytest_cid"
+license=('MIT')
+depends=('python'
+ 'python-setuptools'
+ 'python-cid'
+ )
+checkdepends=()
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('61a1c282220ad1ad419cbfce7c33b3a84781be7a9edae9145da924ab2aaccfe8')