summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2022-04-19 11:36:04 -0300
committerRafael Fontenelle2022-04-19 11:36:04 -0300
commita4b52ee9a8216c542344084fc0269b092ec6224d (patch)
tree963e9af13a8f553b17920e171f7f75d83030e8de
parentbc4d58dc92a4807129af6dafac38de7825eaf4c9 (diff)
downloadaur-a4b52ee9a8216c542344084fc0269b092ec6224d.tar.gz
Drop python2 version
python2-pytest is no longer available, breaking python2 version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 7 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07c356a06f61..b8ef80114fe0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,13 @@
pkgbase = python-pytest-datafiles
pkgdesc = py.test plugin to create a 'tmpdir' containing predefined files/directories.
pkgver = 2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/omarkohl/pytest-datafiles
arch = any
license = MIT
- makedepends = python-pytest
- makedepends = python2-pytest
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python-pytest
source = https://pypi.org/packages/source/p/pytest-datafiles/pytest-datafiles-2.0.tar.gz
sha256sums = 143329cbb1dbbb07af24f88fa4668e2f59ce233696cf12c49fd1c98d1756dbf9
pkgname = python-pytest-datafiles
- depends = python-pytest
-
-pkgname = python2-pytest-datafiles
- depends = python2-pytest
-
diff --git a/PKGBUILD b/PKGBUILD
index dd4ef233c701..0f8a69d0e0f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,24 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
_name=pytest-datafiles
-pkgname=('python-pytest-datafiles' 'python2-pytest-datafiles')
-pkgbase=python-$_name
+pkgname=python-pytest-datafiles
pkgver=2.0
-pkgrel=2
+pkgrel=3
pkgdesc="py.test plugin to create a 'tmpdir' containing predefined files/directories."
arch=(any)
url="https://github.com/omarkohl/pytest-datafiles"
license=('MIT')
-makedepends=(python-pytest python2-pytest python-setuptools python2-setuptools)
+depends=(python-pytest)
+makedepends=(python-setuptools)
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('143329cbb1dbbb07af24f88fa4668e2f59ce233696cf12c49fd1c98d1756dbf9')
-prepare() {
- cp -a $_name-$pkgver{,-py2}
-}
-
build() {
cd "$srcdir/$_name-$pkgver"
python setup.py build
-
- cd "$srcdir/$_name-$pkgver-py2"
- python2 setup.py build
}
-package_python-pytest-datafiles() {
- depends=(python-pytest)
+package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_python2-pytest-datafiles() {
- depends=(python2-pytest)
- cd "$srcdir/$_name-$pkgver-py2"
- python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}