summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElio Duarte2018-12-15 13:03:46 -0200
committerElio Duarte2018-12-15 13:06:13 -0200
commit798c90f07505db0b682b080c56c3556ca84dc459 (patch)
treeedbd1a0625d8313880d340dfedf280e44a2bae5f
downloadaur-798c90f07505db0b682b080c56c3556ca84dc459.tar.gz
First commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86f2a1d00885
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pytest-describe
+ pkgdesc = Architectural foundation for Python applications
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/ropez/pytest-describe
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-pytest
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pytest-describe/pytest-describe-0.11.1.tar.gz
+ sha256sums = bd6be131452b7822c872735ffe53ce3931b3b80cbbad1647c2b482cc9ef3d00e
+
+pkgname = python-pytest-describe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e9355c4e593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
+_pkgname=pytest-describe
+pkgname=python-$_pkgname
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="Architectural foundation for Python applications"
+arch=('any')
+url="https://github.com/ropez/pytest-describe"
+license=('Apache')
+depends=('python-pytest')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('bd6be131452b7822c872735ffe53ce3931b3b80cbbad1647c2b482cc9ef3d00e')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: