summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-01-15 16:03:01 +0800
committerUniversebenzene2021-01-15 16:03:01 +0800
commit084e62b859433079f7385b8b8f15a5c4e2b4f4f9 (patch)
treea3620ea6d64ab6422fcd2272fceeaada219067a4
parent034fc4b0caa91feeaaf91ea235f3b94aac94750f (diff)
downloadaur-084e62b859433079f7385b8b8f15a5c4e2b4f4f9.tar.gz
Update to version 0.9.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c68a864c2135..8e747a803930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.8.0
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = i686
arch = x86_64
license = BSD
- makedepends = python-setuptools
- depends = python-pytest>=4.0
- depends = python-pip
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.8.0.tar.gz
- md5sums = a3fb5901026a8550723dd5882f5fc7f4
+ makedepends = python-setuptools-scm
+ depends = python-pytest>=4.6
+ depends = python-setuptools>=30.3.0
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.9.0.tar.gz
+ md5sums = 90806e2a49a818a0eb09db3ff20fa004
pkgname = python-pytest-doctestplus
diff --git a/PKGBUILD b/PKGBUILD
index 8ba2bd5a792d..7f8688cb7838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-doctestplus
_pyname=${pkgname#python-}
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('i686' 'x86_64')
url="https://github.com/astropy/pytest-doctestplus"
license=('BSD')
-depends=('python-pytest>=4.0' 'python-pip')
-makedepends=('python-setuptools')
+depends=('python-pytest>=4.6' 'python-setuptools>=30.3.0')
+makedepends=('python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('a3fb5901026a8550723dd5882f5fc7f4')
+md5sums=('90806e2a49a818a0eb09db3ff20fa004')
build() {
cd ${srcdir}/${_pyname}-${pkgver}