summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-09-22 16:39:32 +0800
committerUniversebenzene2021-09-22 16:39:32 +0800
commit0f21c65a4a40f8325a94a6ddce349925423d5ae0 (patch)
treed25fed409ceb444c2944739791905922cb02ea55
parent9a6b0c4b1fd61f0a341c39198709bb792bde1f60 (diff)
downloadaur-0f21c65a4a40f8325a94a6ddce349925423d5ae0.tar.gz
Correct arch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c0879ba3423..578931220c79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,15 +3,14 @@ pkgbase = python-pytest-doctestplus
pkgver = 0.11.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
- arch = i686
- arch = x86_64
+ arch = any
license = BSD
checkdepends = python-pytest-remotedata
makedepends = python-setuptools-scm
- depends = python-pytest>=4.6
- depends = python-setuptools>=30.3.0
- depends = python-packaging>=17.0
source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.11.0.tar.gz
md5sums = c759b220acb20d6dc6b2247369719ef3
pkgname = python-pytest-doctestplus
+ depends = python-pytest>=4.6
+ depends = python-setuptools>=30.3.0
+ depends = python-packaging>=17.0
diff --git a/PKGBUILD b/PKGBUILD
index 72857de93ed4..de2c0eabea1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
-pkgname=python-pytest-doctestplus
-_pyname=${pkgname#python-}
+pkgbase=python-pytest-doctestplus
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}")
+#"python-${_pyname}-doc")
pkgver=0.11.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/astropy/pytest-doctestplus"
license=('BSD')
-depends=('python-pytest>=4.6' 'python-setuptools>=30.3.0' 'python-packaging>=17.0')
makedepends=('python-setuptools-scm')
+#'python-sphinx')
checkdepends=('python-pytest-remotedata')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
md5sums=('c759b220acb20d6dc6b2247369719ef3')
@@ -21,6 +23,8 @@ build() {
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py build
+# cd ${srcdir}/${_pyname}-${pkgver}/tests
+# PYTHONPATH="../build/lib" make html
}
check() {
@@ -32,10 +36,23 @@ check() {
PYTHONPATH="build/lib" pytest || warning "Tests failed"
}
-package() {
+package_python-pytest-doctestplus() {
+ depends=('python-pytest>=4.6' 'python-setuptools>=30.3.0' 'python-packaging>=17.0')
+# optdepends=('python-pytest-doctestplus-doc: Documentation for pytest-doctestplus')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 licenses/* -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
}
+
+#package_python-pytest-doctestplus-doc() {
+# pkgdesc="Documentation for pytes-doctestplus"
+# cd ${srcdir}/${_pyname}-${pkgver}/tests/_build
+#
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../licenses/*
+# install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.rst
+# install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+# cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+#}