summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-02-26 14:19:21 +0800
committerUniversebenzene2022-02-26 14:19:21 +0800
commit34ff5ad649a62acfd256e9f7e37ee978ee62f27d (patch)
tree5f70185ac17b3483da6ee0146915259351bdd618
parentfa47735fa4f9f75850d135c44923242eb962acfb (diff)
downloadaur-34ff5ad649a62acfd256e9f7e37ee978ee62f27d.tar.gz
Update to version 0.12.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a791a900425c..a894c7da859e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.11.2
+ pkgver = 0.12.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = any
license = BSD
checkdepends = python-pytest-remotedata
makedepends = python-setuptools-scm
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.11.2.tar.gz
- md5sums = 0722247b329b08ce2084534e185b66a5
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.12.0.tar.gz
+ md5sums = 5b8de28bddb27303480a303b171e25a3
pkgname = python-pytest-doctestplus
depends = python-pytest>=4.6
diff --git a/PKGBUILD b/PKGBUILD
index 7959f4daf826..b064c735f9ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@ pkgbase=python-pytest-doctestplus
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.11.2
+pkgver=0.12.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('any')
url="https://github.com/astropy/pytest-doctestplus"
license=('BSD')
-makedepends=('python-setuptools-scm')
+makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
#'python-sphinx')
checkdepends=('python-pytest-remotedata')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('0722247b329b08ce2084534e185b66a5')
+md5sums=('5b8de28bddb27303480a303b171e25a3')
prepare() {
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
@@ -22,7 +22,7 @@ prepare() {
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
# cd ${srcdir}/${_pyname}-${pkgver}/tests
# PYTHONPATH="../build/lib" make html
}
@@ -44,7 +44,7 @@ package_python-pytest-doctestplus() {
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 licenses/* -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
#package_python-pytest-doctestplus-doc() {