summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-08-12 12:09:32 +0800
committerUniversebenzene2023-08-12 12:09:32 +0800
commit5e00023c79ece0facea8ea3554b2dc41b7629677 (patch)
tree759495e826526509a4d691f4ed897c1d187132fd
parent9c603c1584860de087450fc0e3a5e87d84bd09f8 (diff)
downloadaur-5e00023c79ece0facea8ea3554b2dc41b7629677.tar.gz
Update to version 1.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ca477d2e9f8..5958bbf9e0a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.13.0
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = any
@@ -11,8 +11,8 @@ pkgbase = python-pytest-doctestplus
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.13.0.tar.gz
- md5sums = f0ad13f205a300b79b5a5aa4fcab4309
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-1.0.0.tar.gz
+ md5sums = cd3f754dd96f14f7b6a23b1a09c8ccb3
pkgname = python-pytest-doctestplus
depends = python-pytest>=4.6
diff --git a/PKGBUILD b/PKGBUILD
index b3ec045d4074..fb846dc96d32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-pytest-doctestplus
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.13.0
+pkgver=1.0.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('any')
@@ -14,7 +14,7 @@ makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-insta
checkdepends=('python-pytest-remotedata'
'python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('f0ad13f205a300b79b5a5aa4fcab4309')
+md5sums=('cd3f754dd96f14f7b6a23b1a09c8ccb3')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -33,7 +33,7 @@ check() {
ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
build/lib/${_pyname/-/_}-${pkgver}-py$(get_pyver .).egg-info
- PYTHONPATH="build/lib" pytest || warning "Tests failed" # -vv --color=yes
+ PYTHONPATH="build/lib" pytest -vv -l -ra --color=yes -o console_output_style=count #|| warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
}
package_python-pytest-doctestplus() {