summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-04-30 17:51:51 +0800
committerUniversebenzene2020-04-30 17:51:51 +0800
commit774b5d02fb82666029c04c2a52a3750e57ee8b8c (patch)
treecd36b285cf6c3130f3f3aa3c21722353f4f8464e
parent04802a5944442dfbbf5dbaede1dd3c1e68cbafb5 (diff)
downloadaur-774b5d02fb82666029c04c2a52a3750e57ee8b8c.tar.gz
Update to version 0.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a9681d103db..d27f76cebcbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = i686
arch = x86_64
license = BSD
makedepends = python-setuptools
- depends = python-pytest>=3.0
- depends = python-six
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.5.0.tar.gz
- md5sums = f9136bd78001a83b9a39f8cfdad2926e
+ depends = python-pytest>=4.0
+ depends = python-pip
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.6.0.tar.gz
+ md5sums = 4d67aac1c5a69a3681164d2d9e79d2ff
pkgname = python-pytest-doctestplus
diff --git a/PKGBUILD b/PKGBUILD
index b41ef7477243..8f5c9ee652fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,28 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-doctestplus
_pyname=${pkgname#python-}
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('i686' 'x86_64')
url="https://github.com/astropy/pytest-doctestplus"
license=('BSD')
-depends=('python-pytest>=3.0' 'python-six')
+depends=('python-pytest>=4.0' 'python-pip')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('f9136bd78001a83b9a39f8cfdad2926e')
+md5sums=('4d67aac1c5a69a3681164d2d9e79d2ff')
+
+#build() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# python setup.py build
+#}
+
+#check() {
+# cd ${srcdir}/${_pyname}-${pkgver}
+#
+# PYTHONPATH="build/lib" pytest
+#}
package() {
cd ${srcdir}/${_pyname}-${pkgver}