summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-09-22 16:09:31 +0800
committerUniversebenzene2021-09-22 16:09:31 +0800
commit9a6b0c4b1fd61f0a341c39198709bb792bde1f60 (patch)
treee31486be6e469aa1bb75bb8c99af577155dcbd07
parentb5bd50f00afa118f7d0f2422472f0da979dea18b (diff)
downloadaur-9a6b0c4b1fd61f0a341c39198709bb792bde1f60.tar.gz
Update to version 0.11.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aa05989df42..6c0879ba3423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.10.1
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = i686
arch = x86_64
license = BSD
+ checkdepends = python-pytest-remotedata
makedepends = python-setuptools-scm
depends = python-pytest>=4.6
depends = python-setuptools>=30.3.0
depends = python-packaging>=17.0
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.10.1.tar.gz
- md5sums = 3f7627713cf25c5726659e05b5ed16b8
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.11.0.tar.gz
+ md5sums = c759b220acb20d6dc6b2247369719ef3
pkgname = python-pytest-doctestplus
diff --git a/PKGBUILD b/PKGBUILD
index 096658aa7c11..72857de93ed4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-doctestplus
_pyname=${pkgname#python-}
-pkgver=0.10.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('i686' 'x86_64')
@@ -9,8 +9,13 @@ url="https://github.com/astropy/pytest-doctestplus"
license=('BSD')
depends=('python-pytest>=4.6' 'python-setuptools>=30.3.0' 'python-packaging>=17.0')
makedepends=('python-setuptools-scm')
+checkdepends=('python-pytest-remotedata')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('3f7627713cf25c5726659e05b5ed16b8')
+md5sums=('c759b220acb20d6dc6b2247369719ef3')
+
+prepare() {
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -21,6 +26,9 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
+ export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname/-/_}*egg-info \
+ build/lib/${_pyname/-/_}-${pkgver}-py${_pyver}.egg-info
PYTHONPATH="build/lib" pytest || warning "Tests failed"
}