summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-06-06 11:12:21 +0800
committerUniversebenzene2020-06-06 11:12:21 +0800
commitb106a55d0bc71ff733aa09f699dd9cd597471473 (patch)
treea5d74b922e70cf418e947605f0abb75346e21d18
parent774b5d02fb82666029c04c2a52a3750e57ee8b8c (diff)
downloadaur-b106a55d0bc71ff733aa09f699dd9cd597471473.tar.gz
Update to version 0.7.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d27f76cebcbf..7d0519a8c79c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pytest-doctestplus
pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/astropy/pytest-doctestplus
arch = i686
@@ -9,8 +9,8 @@ pkgbase = python-pytest-doctestplus
makedepends = python-setuptools
depends = python-pytest>=4.0
depends = python-pip
- source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.6.0.tar.gz
- md5sums = 4d67aac1c5a69a3681164d2d9e79d2ff
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.7.0.tar.gz
+ md5sums = 85c4d8a5fcbe7ab4d513e523c9c99342
pkgname = python-pytest-doctestplus
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 8f5c9ee652fb..37652429f5f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-doctestplus
_pyname=${pkgname#python-}
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=1
pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
arch=('i686' 'x86_64')
@@ -10,19 +10,19 @@ license=('BSD')
depends=('python-pytest>=4.0' 'python-pip')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('4d67aac1c5a69a3681164d2d9e79d2ff')
+md5sums=('85c4d8a5fcbe7ab4d513e523c9c99342')
-#build() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# python setup.py build
-#}
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
+}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# PYTHONPATH="build/lib" pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ PYTHONPATH="build/lib" pytest || warning "Tests failed"
+}
package() {
cd ${srcdir}/${_pyname}-${pkgver}