summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-15 00:26:33 +0800
committerUniversebenzene2018-02-15 00:26:33 +0800
commitb4f3a3bf117ba5fcf35756ceca90e45aff062dec (patch)
tree51a25ed417a1cfe96a8cf882f5da4634a4a63218
downloadaur-b4f3a3bf117ba5fcf35756ceca90e45aff062dec.tar.gz
Initial import 0.1.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7fca11f14f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Feb 14 16:25:58 UTC 2018
+pkgbase = python-pytest-doctestplus
+ pkgdesc = Pytest plugin that provides advanced features for testing example code in documentation
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/astropy/pytest-doctestplus
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pytest
+ depends = python-six
+ source = https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-0.1.2.tar.gz
+ md5sums = 4929b135dfff1b1bded726a2c719c101
+
+pkgname = python-pytest-doctestplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fa91d11e51d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-pytest-doctestplus
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Pytest plugin that provides advanced features for testing example code in documentation"
+arch=('i686' 'x86_64')
+url="https://github.com/astropy/pytest-doctestplus"
+license=('BSD')
+depends=('python' 'python-pytest' 'python-six')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/p/pytest-doctestplus/pytest-doctestplus-${pkgver}.tar.gz")
+md5sums=('4929b135dfff1b1bded726a2c719c101')
+
+package() {
+ cd ${srcdir}/pytest-doctestplus-${pkgver}
+
+ install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}