summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-21 13:40:32 -0600
committerLuis Martinez2022-02-21 13:40:32 -0600
commit252ef1c10a4f69afda4518e2199a7055bc54b1dc (patch)
tree3ce74369003d49de4d245f714208dfe96c596ea3
parentee57e65630ddc0cf666c0182b8415b8dd67008f7 (diff)
downloadaur-252ef1c10a4f69afda4518e2199a7055bc54b1dc.tar.gz
replace python-install with python-installer
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96ca27acb769..757d33ede0b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytest-md-report
pkgdesc = Pytest plugin to create a report in Markdown table format
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thombashi/pytest-md-report
arch = any
license = MIT
@@ -10,7 +10,7 @@ pkgbase = python-pytest-md-report
checkdepends = python-pytz
makedepends = python-setuptools
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-wheel
depends = python-pytablewriter
depends = python-pytest
diff --git a/PKGBUILD b/PKGBUILD
index 9425a43a3edb..5cce2c57e036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=python-pytest-md-report
_name="${pkgname#python-}"
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Pytest plugin to create a report in Markdown table format'
arch=('any')
url='https://github.com/thombashi/pytest-md-report'
license=('MIT')
depends=('python-pytablewriter' 'python-pytest' 'python-tcolorpy' 'python-typepy')
-makedepends=('python-setuptools' 'python-build' 'python-install' 'python-wheel')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest' 'python-dateutil' 'python-pytz')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
"$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz.asc")
@@ -20,7 +20,7 @@ validpgpkeys=('BCF9203E5E80B5607EAE6FDD98CDA9A5F0BFC367')
build() {
cd "$_name-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
check() {
@@ -31,7 +31,7 @@ check() {
package() {
export PYTHONHASHSEED=0
cd "$_name-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 'README.rst' -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname"
}