summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-02-15 00:29:21 +0800
committerUniversebenzene2018-02-15 00:29:21 +0800
commit6df1fed6852461b142e65c0c4a2200f0cb7d5104 (patch)
treede3e1325a6ddefd73c2c26ecc8c0d534f424606b
downloadaur-6df1fed6852461b142e65c0c4a2200f0cb7d5104.tar.gz
Initial import 0.2.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caf977c860ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Feb 14 16:29:05 UTC 2018
+pkgbase = python-pytest-openfiles
+ pkgdesc = Pytest plugin for detecting file handles that were inadvertently left open at the end of unit tests
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/astropy/pytest-openfiles
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pytest
+ depends = python-psutil
+ depends = python-six
+ source = https://files.pythonhosted.org/packages/source/p/pytest-openfiles/pytest-openfiles-0.2.0.tar.gz
+ md5sums = 67be17f8a5eec42a23ed2c0cb1cc3894
+
+pkgname = python-pytest-openfiles
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81c14482f314
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgname=python-pytest-openfiles
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Pytest plugin for detecting file handles that were inadvertently left open at the end of unit tests"
+arch=('i686' 'x86_64')
+url="https://github.com/astropy/pytest-openfiles"
+license=('BSD')
+depends=('python' 'python-pytest' 'python-psutil' 'python-six')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/p/pytest-openfiles/pytest-openfiles-${pkgver}.tar.gz")
+md5sums=('67be17f8a5eec42a23ed2c0cb1cc3894')
+
+package() {
+ cd ${srcdir}/pytest-openfiles-${pkgver}
+
+ install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ rm -rf ${pkgdir}/usr/lib/python3.6/site-packages/tests
+}