summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-01-07 23:56:53 +0800
committerUniversebenzene2019-01-07 23:56:53 +0800
commit9cfb59cda11600a8d08940781e81f4ecf1b0f2bf (patch)
treee111b0def4d39f6c966f6f228021ddfde9055bc9
parentcc09692d4e3dcd3ad63f364780d6207fcd986202 (diff)
downloadaur-9cfb59cda11600a8d08940781e81f4ecf1b0f2bf.tar.gz
Update to version 0.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d23f1440626a..fd950833bc7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Nov 28 13:56:46 UTC 2018
+# Mon Jan 7 15:55:46 UTC 2019
pkgbase = python-pytest-openfiles
pkgdesc = Pytest plugin for detecting file handles that were inadvertently left open at the end of unit tests
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/astropy/pytest-openfiles
arch = i686
@@ -12,8 +12,8 @@ pkgbase = python-pytest-openfiles
depends = python-pytest>=2.8.0
depends = python-psutil
depends = python-six
- source = https://files.pythonhosted.org/packages/source/p/pytest-openfiles/pytest-openfiles-0.3.1.tar.gz
- md5sums = 44cf5a6664388f69033f2ead77bb27ae
+ source = https://files.pythonhosted.org/packages/source/p/pytest-openfiles/pytest-openfiles-0.3.2.tar.gz
+ md5sums = b219c5487f7630c3944973cf24709340
pkgname = python-pytest-openfiles
diff --git a/PKGBUILD b/PKGBUILD
index b830fc96c42f..424cb2d61194 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-pytest-openfiles
-pkgver=0.3.1
+_pyname=${pkgname#python-}
+pkgver=0.3.2
pkgrel=1
pkgdesc="Pytest plugin for detecting file handles that were inadvertently left open at the end of unit tests"
arch=('i686' 'x86_64')
@@ -8,14 +9,13 @@ url="https://github.com/astropy/pytest-openfiles"
license=('BSD')
depends=('python-pytest>=2.8.0' 'python-psutil' 'python-six')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/p/pytest-openfiles/pytest-openfiles-${pkgver}.tar.gz")
-md5sums=('44cf5a6664388f69033f2ead77bb27ae')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('b219c5487f7630c3944973cf24709340')
package() {
- cd ${srcdir}/pytest-openfiles-${pkgver}
+ cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
- rm -rf ${pkgdir}/usr/lib/python3.6/site-packages/tests
}