summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Rümpelein2015-09-13 14:45:51 +0200
committerOliver Rümpelein2015-09-13 14:45:51 +0200
commit3edb3569a96e805fb7212f7cad01e47566b247dd (patch)
treefb83232b3997fa1ccec2438c1d98be642384c559
downloadaur-3edb3569a96e805fb7212f7cad01e47566b247dd.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8189da0f222
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pytest-pep8
+ pkgdesc = pytest plugin to check PEP8 requirements.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://bitbucket.org/pytest-dev/pytest-pep8
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = pep8
+ depends = python
+ depends = python-pip
+ depends = python-pytest
+ depends = python-pytest-cache
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pytest-pep8/pytest-pep8-1.0.6.tar.gz
+ md5sums = 3debd0bac8f63532ae70c7351e73e993
+ sha256sums = 032ef7e5fa3ac30f4458c73e05bb67b0f036a8a5cb418a534b3170f89f120318
+
+pkgname = python-pytest-pep8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6767fccc1df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Oliver Rümpelein <oli_r@fg4f.de>
+# Based upon work of Jeff Parent <jecxjo@sdf.lonestar.org>
+pkgname=python-pytest-pep8
+_pypiname=pytest-pep8
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="pytest plugin to check PEP8 requirements."
+arch=('any')
+url="https://bitbucket.org/pytest-dev/pytest-pep8"
+license=('MIT')
+depends=('pep8'
+ 'python'
+ 'python-pip'
+ 'python-pytest'
+ 'python-pytest-cache')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/p/pytest-pep8/pytest-pep8-$pkgver.tar.gz")
+md5sums=('3debd0bac8f63532ae70c7351e73e993')
+sha256sums=('032ef7e5fa3ac30f4458c73e05bb67b0f036a8a5cb418a534b3170f89f120318')
+
+build() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py install --root="$pkgdir"/ --prefix="/usr"
+}