summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2018-08-22 14:28:51 -0300
committerRafael Fontenelle2018-08-22 14:28:51 -0300
commit7f917ab3a665f0e9dd020aa64b4026377654a9ab (patch)
treed818eb7e90ecba497e02c2f7d0a8d025fd0857e1
parent2d0d2cfb55b58ab8882c915f81cde6762e128a02 (diff)
downloadaur-7f917ab3a665f0e9dd020aa64b4026377654a9ab.tar.gz
Revive, Add python2 version
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD53
3 files changed, 64 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 914fbef8df87..d7e05bed9000 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = python-pytest-pep8
- pkgdesc = pytest plugin to check PEP8 requirements.
+ pkgdesc = pytest plugin to check PEP8 requirements
pkgver = 1.0.6
- pkgrel = 3
+ pkgrel = 4
url = https://bitbucket.org/pytest-dev/pytest-pep8
arch = any
license = MIT
- makedepends = python-setuptools
- depends = pep8
- depends = python
- depends = python-pip
- depends = python-pytest
- depends = python-pytest-cache
- options = !emptydirs
- source = https://pypi.python.org/packages/source/p/pytest-pep8/pytest-pep8-1.0.6.tar.gz
- md5sums = 3debd0bac8f63532ae70c7351e73e993
+ makedepends = python-pycodestyle
+ makedepends = python-pytest-cache
+ makedepends = python2-pycodestyle
+ makedepends = python2-pytest-cache
+ source = https://pypi.org/packages/source/p/pytest-pep8/pytest-pep8-1.0.6.tar.gz
sha256sums = 032ef7e5fa3ac30f4458c73e05bb67b0f036a8a5cb418a534b3170f89f120318
pkgname = python-pytest-pep8
+ depends = python-pycodestyle
+ depends = python-pytest-cache
+
+pkgname = python2-pytest-pep8
+ depends = python2-pycodestyle
+ depends = python2-pytest-cache
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e32c14d2a7b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
index 753dd79a70e4..8c220f0e2357 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,42 @@
-# Maintainer: Oliver Rümpelein <oli_r@fg4f.de>
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Contributor: Oliver Rümpelein <oli_r@fg4f.de>
# Based upon work of Jeff Parent <jecxjo@sdf.lonestar.org>
-pkgname=python-pytest-pep8
-_pypiname=pytest-pep8
+_name=pytest-pep8
+pkgname=('python-pytest-pep8' 'python2-pytest-pep8')
+pkgbase=python-$_name
pkgver=1.0.6
-pkgrel=3
-pkgdesc="pytest plugin to check PEP8 requirements."
-arch=('any')
+pkgrel=4
+pkgdesc="pytest plugin to check PEP8 requirements"
+arch=(any)
url="https://bitbucket.org/pytest-dev/pytest-pep8"
license=('MIT')
-depends=('pep8'
- 'python'
- 'python-pip'
- 'python-pytest'
- 'python-pytest-cache')
-makedepends=('python-setuptools')
-options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/p/pytest-pep8/pytest-pep8-$pkgver.tar.gz")
-md5sums=('3debd0bac8f63532ae70c7351e73e993')
+makedepends=(python-pycodestyle python-pytest-cache
+ python2-pycodestyle python2-pytest-cache) # setuptools included
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('032ef7e5fa3ac30f4458c73e05bb67b0f036a8a5cb418a534b3170f89f120318')
+prepare() {
+ cp -a $_name-$pkgver{,-py2}
+}
+
build() {
- cd "$srcdir/$_pypiname-$pkgver"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+
+ cd "$srcdir/$_name-$pkgver-py2"
+ python2 setup.py build
+}
+
+package_python-pytest-pep8() {
+ depends=(python-pycodestyle python-pytest-cache)
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-package() {
- cd "$srcdir/$_pypiname-$pkgver"
- python setup.py install --root="$pkgdir"/ --prefix="/usr" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package_python2-pytest-pep8() {
+ depends=(python2-pycodestyle python2-pytest-cache)
+ cd "$srcdir/$_name-$pkgver-py2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}