summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTong Chunli2018-11-02 22:12:42 +0800
committerTong Chunli2018-11-02 22:12:42 +0800
commitb3d8673b5ca2c25c5f689f5a14194a990ff4ce0e (patch)
treee5114429661d306138ea21b8cd417910b47d212f
downloadaur-b3d8673b5ca2c25c5f689f5a14194a990ff4ce0e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e37c165aee6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pytest-repeat
+ pkgdesc = pytest-repeat is a plugin for py.test that makes it easy to repeat a single test, or multiple tests, a specific number of times.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://pypi.org/project/pytest-repeat
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-six
+ depends = python-attrs
+ depends = python-atomicwrites
+ depends = python-pluggy
+ depends = python-more-itertools
+ depends = python-pytest
+ source = https://files.pythonhosted.org/packages/a2/87/992d24e12645abdb1dc20cad27d062285ba70b2d315defef518ee4912486/pytest-repeat-0.7.0.tar.gz
+ sha256sums = 637e68dd615e850b47b2dee0edf72bcede44de6a5335837fe2980daaf0cdab2b
+
+pkgname = python-pytest-repeat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b9b19e1052f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+pkgname=python-pytest-repeat
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="pytest-repeat is a plugin for py.test that makes it easy to repeat a single test, or multiple tests, a specific number of times."
+arch=(any)
+url="https://pypi.org/project/pytest-repeat"
+license=('BSD')
+depends=('python-six' 'python-attrs' 'python-atomicwrites' 'python-pluggy' 'python-more-itertools' 'python-pytest')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/a2/87/992d24e12645abdb1dc20cad27d062285ba70b2d315defef518ee4912486/pytest-repeat-$pkgver.tar.gz")
+sha256sums=('637e68dd615e850b47b2dee0edf72bcede44de6a5335837fe2980daaf0cdab2b')
+
+package() {
+ cd ${srcdir}/pytest-repeat-${pkgver}
+
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}