summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-02-21 01:34:33 -0300
committerDanilo J. S. Bellini2022-02-21 01:34:33 -0300
commit702e6464dae10ced86f8a001d2bd1e567b93460c (patch)
treefe7610e76324869b55557b2b5dacc47cd7838713
downloadaur-702e6464dae10ced86f8a001d2bd1e567b93460c.tar.gz
v3.2.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c007d1d50ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pytest-spec
+ pkgdesc = Plugin to display pytest execution output like a specification
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://github.com/pchomik/pytest-spec
+ arch = any
+ license = GPL
+ checkdepends = python-mock
+ checkdepends = python-pytest-flake8
+ checkdepends = python-pytest-cov
+ makedepends = python-poetry
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python-six
+ depends = python-pytest
+ source = pytest-spec-3.2.0.tar.gz::https://github.com/pchomik/pytest-spec/archive/refs/tags/3.2.0.tar.gz
+ sha256sums = 5b906864c3c8fe4be065edd22ea14960d5cc98b65fc3e2c5ee976d6f249d28a4
+
+pkgname = python-pytest-spec
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c60726884e70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=pytest-spec
+pkgname=(python-pytest-spec)
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Plugin to display pytest execution output like a specification"
+arch=(any)
+url='https://github.com/pchomik/pytest-spec'
+license=(GPL)
+makedepends=(python-poetry python-build python-installer)
+depends=(python-six python-pytest)
+checkdepends=(python-mock python-pytest-flake8 python-pytest-cov)
+source=("pytest-spec-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=(5b906864c3c8fe4be065edd22ea14960d5cc98b65fc3e2c5ee976d6f249d28a4)
+
+prepare() {
+ cd "$srcdir/pytest-spec-$pkgver"
+
+ # Let the "check" step not require itself
+ sed -i 's/--spec //' setup.cfg
+
+ # Remove tests that aren't tests for pytest-spec
+ rm -rf test/test_{formats,results}
+
+ # Avoid installing the license file in site-packages
+ sed -i /LICENSE.txt/d pyproject.toml
+}
+
+build() {
+ cd "$srcdir/pytest-spec-$pkgver"
+ python -m build -wnxo dist
+}
+
+check() {
+ cd "$srcdir/pytest-spec-$pkgver"
+ python -m pytest
+}
+
+package() {
+ cd "$srcdir/pytest-spec-$pkgver"
+ python -m installer --destdir="$pkgdir" \
+ "dist/pytest_spec-$pkgver-py2.py3-none-any.whl"
+}