summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Stańczak2017-03-20 21:42:30 +0100
committerDominik Stańczak2017-03-20 21:43:10 +0100
commit5b305e9b05ee51a5ce0d3d05b6e461dc4a07c07a (patch)
tree02b32b128ccaffc38ea2cc6fd371e7468bc40169
downloadaur-5b305e9b05ee51a5ce0d3d05b6e461dc4a07c07a.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f27bea5a01d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pytest-watch
+ pkgdesc = Local continuous test runner with pytest and watchdog.
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = https://github.com/joeyespo/pytest-watch
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-watchdog
+ source = https://pypi.python.org/packages/e9/88/69b94fe4cb3d3b106b184056bc80ade6b0a9062e5a9a1cb65aec58831281/pytest-watch-4.1.0.zip
+ md5sums = 4048e6e4a420ee54ed1318c71153e593
+
+pkgname = python-pytest-watch
+ depends = python
+ depends = python-watchdog
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..597fb1844b82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dominik Stańczak <stanczakdominik at gmail dot com>
+# autogenerated with pip2pkgbuild
+pkgbase=('python-pytest-watch')
+pkgname=('python-pytest-watch')
+_module="pytest-watch"
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Local continuous test runner with pytest and watchdog."
+url="https://github.com/joeyespo/pytest-watch"
+makedepends=('python-setuptools')
+depends=('python' 'python-watchdog')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/e9/88/69b94fe4cb3d3b106b184056bc80ade6b0a9062e5a9a1cb65aec58831281/pytest-watch-${pkgver}.zip")
+md5sums=('4048e6e4a420ee54ed1318c71153e593')
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package_python-pytest-watch() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+