summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-15 23:30:22 +0100
committerNarrat2020-01-15 23:30:22 +0100
commitf934fa2f4bc033bff989034e12a884f4c42b0bfb (patch)
tree6841b3801dedcf8b7f6200b6cd5ea46edc05cad6
parent5b305e9b05ee51a5ce0d3d05b6e461dc4a07c07a (diff)
downloadaur-f934fa2f4bc033bff989034e12a884f4c42b0bfb.tar.gz
update to 4.2.0
and undo this half done split-package
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD27
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f27bea5a01d9..c6c4b17c0eab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pytest-watch
pkgdesc = Local continuous test runner with pytest and watchdog.
- pkgver = 4.1.0
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/joeyespo/pytest-watch
arch = any
@@ -8,10 +8,8 @@ pkgbase = python-pytest-watch
makedepends = python-setuptools
depends = python
depends = python-watchdog
- source = https://pypi.python.org/packages/e9/88/69b94fe4cb3d3b106b184056bc80ade6b0a9062e5a9a1cb65aec58831281/pytest-watch-4.1.0.zip
- md5sums = 4048e6e4a420ee54ed1318c71153e593
+ source = https://files.pythonhosted.org/packages/source/p/pytest-watch/pytest-watch-4.2.0.tar.gz
+ md5sums = 9f854cdf60212c5d1a210c8991619ba4
pkgname = python-pytest-watch
- depends = python
- depends = python-watchdog
diff --git a/PKGBUILD b/PKGBUILD
index 597fb1844b82..7fe448cd47e8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: Dominik Stańczak <stanczakdominik at gmail dot com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Dominik Stańczak <stanczakdominik at gmail dot com>
# autogenerated with pip2pkgbuild
-pkgbase=('python-pytest-watch')
-pkgname=('python-pytest-watch')
-_module="pytest-watch"
-pkgver=4.1.0
+
+pkgbase=python-pytest-watch
+pkgname=python-pytest-watch
+_module=pytest-watch
+pkgver=4.2.0
pkgrel=1
pkgdesc="Local continuous test runner with pytest and watchdog."
url="https://github.com/joeyespo/pytest-watch"
@@ -11,16 +13,17 @@ makedepends=('python-setuptools')
depends=('python' 'python-watchdog')
license=('MIT')
arch=('any')
-source=("https://pypi.python.org/packages/e9/88/69b94fe4cb3d3b106b184056bc80ade6b0a9062e5a9a1cb65aec58831281/pytest-watch-${pkgver}.zip")
-md5sums=('4048e6e4a420ee54ed1318c71153e593')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+md5sums=('9f854cdf60212c5d1a210c8991619ba4')
+
+
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build
}
-package_python-pytest-watch() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+package() {
+ cd "${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}