summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Volodin [Никита Володин]2015-06-22 23:45:55 -0300
committerNikita Volodin [Никита Володин]2015-06-22 23:54:20 -0300
commit2f96679b8275c16a863564e903d018cc4bd9bf02 (patch)
tree9c6456c85739d8e46375ccc859fa0ab447e08cde
downloadaur-2f96679b8275c16a863564e903d018cc4bd9bf02.tar.gz
feat(python-python-ddp): initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad9dd7eabbf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-python-ddp
+ pkgdesc = An event driven ddp client
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/hharnisc/python-ddp
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyee
+ depends = python-ws4py
+ depends = python-meteor-ejson
+ source = https://pypi.python.org/packages/source/p/python-ddp/python-ddp-0.1.5.tar.gz
+ md5sums = df80774a52f84258154c9371b6acf48d
+
+pkgname = python-python-ddp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e7aa272f6d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*~
+
+pkg/
+src/
+
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5331725742e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Automatically generated by pip2arch on 2015-06-22
+
+pkgname=python-python-ddp
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="An event driven ddp client"
+url="https://github.com/hharnisc/python-ddp"
+depends=('python' 'python-pyee' 'python-ws4py' 'python-meteor-ejson')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/p/python-ddp/python-ddp-$pkgver.tar.gz")
+md5sums=('df80774a52f84258154c9371b6acf48d')
+
+build() {
+ cd "$srcdir/python-ddp-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/python-ddp-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}