diff options
author | xiota | 2023-12-28 21:39:38 -0800 |
---|---|---|
committer | xiota | 2023-12-28 21:39:38 -0800 |
commit | 7a6fde0a4b3bddd64298bbfd588c2a1e6de12430 (patch) | |
tree | ec3d7a6ac4a6ca42117af7308138a30372597ede | |
parent | f6237c3fd42fc8295e80a86fab302e1d2518461f (diff) | |
download | aur-7a6fde0a4b3bddd64298bbfd588c2a1e6de12430.tar.gz |
2.0.9
-rw-r--r-- | .SRCINFO | 6 | ||||
-rw-r--r-- | PKGBUILD | 15 |
2 files changed, 11 insertions, 10 deletions
@@ -1,6 +1,6 @@ pkgbase = python-python-ffmpeg pkgdesc = Python binding for FFmpeg which provides sync and async APIs - pkgver = 2.0.7 + pkgver = 2.0.9 pkgrel = 1 url = https://github.com/jonghwanhyeon/python-ffmpeg arch = any @@ -18,7 +18,7 @@ pkgbase = python-python-ffmpeg conflicts = python-ffmpeg conflicts = python-ffmpeg-python options = !emptydirs - source = python-ffmpeg-2.0.7.tar.gz::https://github.com/jonghwanhyeon/python-ffmpeg/archive/v2.0.7.tar.gz - sha256sums = c135685a1963480b58d40d0ea95e30ba29651ed005d75ccc8f724548e636f61f + source = python-ffmpeg-2.0.9.tar.gz::https://github.com/jonghwanhyeon/python-ffmpeg/archive/v2.0.9.tar.gz + sha256sums = 73c0f98fe0a54e9484b061013bc95a3e5762fff24e8d81e605f185919f5a5e0e pkgname = python-python-ffmpeg @@ -1,13 +1,15 @@ # Maintainer: xiota / aur.chaotic.cx # options -#: ${_pkgtype:=git} +: ${_build_git:=false} + +[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git" # basic info _module='python-ffmpeg' _pkgname="python-$_module" -pkgname="$_pkgname${_pkgtype:+-$_pkgtype}" -pkgver=2.0.7 +pkgname="$_pkgname${_pkgtype:-}" +pkgver=2.0.9 pkgrel=1 pkgdesc="Python binding for FFmpeg which provides sync and async APIs" url="https://github.com/jonghwanhyeon/python-ffmpeg" @@ -40,7 +42,7 @@ _main_package() { options=(!emptydirs) - if [ "$pkgname" == "$_pkgname" ] ; then + if [ "${_build_git::1}" != "t" ] ; then _main_stable else _main_git @@ -53,7 +55,7 @@ _main_stable() { _pkgsrc="$_module-${_pkgver:?}" _pkgext="tar.gz" source+=("$_pkgsrc.$_pkgext"::"$url/archive/v$_pkgver.$_pkgext") - sha256sums+=('c135685a1963480b58d40d0ea95e30ba29651ed005d75ccc8f724548e636f61f') + sha256sums+=('73c0f98fe0a54e9484b061013bc95a3e5762fff24e8d81e605f185919f5a5e0e') pkgver() { echo "${_pkgver:?}" @@ -73,7 +75,7 @@ _main_git() { sha256sums=('SKIP') pkgver() { - cd "$srcdir/$_pkgsrc" + cd "$_pkgsrc" git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' } } @@ -87,7 +89,6 @@ build() { package() { cd "$_pkgsrc" python -m installer --destdir="$pkgdir" dist/*.whl - install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/" } |