summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Pray2016-04-27 18:27:04 -0700
committerMaxwell Pray2016-04-27 18:27:04 -0700
commit4c6422fafd802485019a880d1e9ed76388c114c3 (patch)
treed65b7859de7345e49031156b649545f709c7c235
downloadaur-4c6422fafd802485019a880d1e9ed76388c114c3.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14767675249d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-python-jenkins
+ pkgdesc = A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server.
+ pkgver = 0.4.12
+ pkgrel = 1
+ url = http://git.openstack.org/cgit/openstack/python-jenkins
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = python-multi_key_dict
+ source = https://pypi.python.org/packages/source/p/python-jenkins/python-jenkins-0.4.12.tar.gz
+ md5sums = 7d57db182ff9e12f2280e1672e40e46d
+
+pkgname = python-python-jenkins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47ab3e361d4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+_pkgname=python-jenkins
+pkgname=python-$_pkgname
+pkgver=0.4.12
+pkgrel=1
+pkgdesc="A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server."
+url="http://git.openstack.org/cgit/openstack/python-jenkins"
+license=("BSD")
+arch=("i686" "x86_64")
+makedepends=("python-setuptools")
+depends=("python" "python-six" "python-multi_key_dict")
+source=("https://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=("7d57db182ff9e12f2280e1672e40e46d")
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}