summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Scarpino2016-11-23 18:33:22 +0100
committerAndrea Scarpino2016-11-23 18:33:22 +0100
commitb4757f9a065241353b6b2ce3e77698ac2a82d2e5 (patch)
tree119097403d7eb3905a50eb667996c91859958e4d
parent4c6422fafd802485019a880d1e9ed76388c114c3 (diff)
downloadaur-b4757f9a065241353b6b2ce3e77698ac2a82d2e5.tar.gz
Update to 0.4.13 and switch to arch any
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 27 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14767675249d..426110998a3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Nov 23 17:27:52 UTC 2016
pkgbase = python-python-jenkins
- pkgdesc = A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server.
- pkgver = 0.4.12
+ pkgdesc = A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server
+ pkgver = 0.4.13
pkgrel = 1
- url = http://git.openstack.org/cgit/openstack/python-jenkins
- arch = i686
- arch = x86_64
+ url = https://git.openstack.org/cgit/openstack/python-jenkins
+ arch = any
license = BSD
makedepends = python-setuptools
depends = python
+ depends = python-pbr
depends = python-six
depends = python-multi_key_dict
- source = https://pypi.python.org/packages/source/p/python-jenkins/python-jenkins-0.4.12.tar.gz
- md5sums = 7d57db182ff9e12f2280e1672e40e46d
+ source = https://pypi.io/packages/source/p/python-jenkins/python-jenkins-0.4.13.tar.gz
+ md5sums = f0d47b7861e7eb6abd728f42b904f08e
pkgname = python-python-jenkins
diff --git a/PKGBUILD b/PKGBUILD
index 47ab3e361d4a..9004e2c10d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,27 @@
-# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
_pkgname=python-jenkins
pkgname=python-$_pkgname
-pkgver=0.4.12
+pkgver=0.4.13
pkgrel=1
-pkgdesc="A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server."
-url="http://git.openstack.org/cgit/openstack/python-jenkins"
-license=("BSD")
-arch=("i686" "x86_64")
-makedepends=("python-setuptools")
-depends=("python" "python-six" "python-multi_key_dict")
-source=("https://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz")
-md5sums=("7d57db182ff9e12f2280e1672e40e46d")
+pkgdesc="A python wrapper for the Jenkins REST API which aims to provide a more conventionally pythonic way of controlling a Jenkins server"
+url='https://git.openstack.org/cgit/openstack/python-jenkins'
+license=('BSD')
+arch=('any')
+makedepends=('python-setuptools')
+depends=('python' 'python-pbr' 'python-six' 'python-multi_key_dict')
+source=("https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('f0d47b7861e7eb6abd728f42b904f08e')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ install -D COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}