summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Winger2020-04-02 13:21:39 -0400
committerBenjamin Winger2020-04-02 13:48:40 -0400
commitcedba6a82b2d45bb3dcae9930cd0cc9545eef977 (patch)
tree2a32c18ebfe659572f6d7be29d7c853bd1c00096
downloadaur-cedba6a82b2d45bb3dcae9930cd0cc9545eef977.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83e700abe8af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-python-sat
+ pkgdesc = A Python library for prototyping with SAT oracles
+ pkgver = 0.1.5.dev10
+ pkgrel = 1
+ url = https://github.com/pysathq/pysat
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-six
+ provides = python-python-sat
+ conflicts = python-python-sat
+ source = https://files.pythonhosted.org/packages/3a/4d/2b121fc0b6224112c932863c7b83e87e5f86c1f44d00d0531581da044525/python-sat-0.1.5.dev10.tar.gz
+ sha512sums = a12797a84b66b227ec5278aa4d4418c0a0f0c3afb661a776111a890e835041a00fd2182a14e4b6b6c534048b4431e27bee545365ccdabfc640f5f649bec206d2
+
+pkgname = python-python-sat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28500754d33d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Benjamin Winger <bmw@disroot.org>
+
+pkgname=python-python-sat
+pkgver=0.1.5.dev10
+pkgrel=1
+pkgdesc="A Python library for prototyping with SAT oracles"
+provides=('python-python-sat')
+conflicts=('python-python-sat')
+arch=(any)
+url="https://github.com/pysathq/pysat"
+license=(GPL3)
+depends=("python" "python-six")
+source=("https://files.pythonhosted.org/packages/3a/4d/2b121fc0b6224112c932863c7b83e87e5f86c1f44d00d0531581da044525/python-sat-0.1.5.dev10.tar.gz")
+sha512sums=('a12797a84b66b227ec5278aa4d4418c0a0f0c3afb661a776111a890e835041a00fd2182a14e4b6b6c534048b4431e27bee545365ccdabfc640f5f649bec206d2')
+
+package() {
+ cd "$srcdir/python-sat-$pkgver"
+ python setup.py install --root $pkgdir
+}