summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-11-17 12:55:42 +0100
committerXiretza2020-11-17 12:55:42 +0100
commit6cd101f6fc792292a295b1ede8731452a3b43c24 (patch)
treeb1d81efffa873e6e0be71947757125bfc8b95cd9
downloadaur-python-pythondata-cpu-vexriscv-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..743f8d632a43
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pythondata-cpu-vexriscv-git
+ pkgdesc = Python module containing verilog files for vexriscv cpu (for use with LiteX)
+ pkgver = 2020.08.r1.g2962f4a
+ pkgrel = 1
+ url = https://github.com/litex-hub/pythondata-cpu-vexriscv
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = python-pythondata-cpu-vexriscv=2020.08.r1.g2962f4a
+ conflicts = python-pythondata-cpu-vexriscv
+ source = git+https://github.com/litex-hub/pythondata-cpu-vexriscv
+ sha256sums = SKIP
+
+pkgname = python-pythondata-cpu-vexriscv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66ad9d3acfd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_srcname=pythondata-cpu-vexriscv
+pkgname="python-$_srcname-git"
+pkgver=2020.08.r1.g2962f4a
+pkgrel=1
+pkgdesc="Python module containing verilog files for vexriscv cpu (for use with LiteX)"
+arch=(any)
+url="https://github.com/litex-hub/pythondata-cpu-vexriscv"
+license=('MIT')
+depends=(python)
+makedepends=(git python-setuptools)
+provides=("${pkgname%%-git}=$pkgver")
+conflicts=("${pkgname%%-git}")
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_srcname"
+ python setup.py build
+}
+
+package() {
+ cd "$_srcname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set et ts=2 syntax=PKGBUILD: