summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill2018-06-13 11:11:41 -0600
committerwill2018-06-13 11:11:41 -0600
commitfe1a760ee5c88b4a1af4ad98ec33a5870656bef7 (patch)
treeb13acb9285dec6a007182180db29658cbe8b4ff7
downloadaur-fe1a760ee5c88b4a1af4ad98ec33a5870656bef7.tar.gz
created package to install pythonnet from github
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f2f53d28a16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pythonnet
+ pkgdesc = pythonnet provides integration with the .NET Common Language Runtime (CLR)
+ pkgver = 2.3.0.r110.g397b0b4
+ pkgrel = 1
+ url = https://pythonnet.github.io/
+ arch = any
+ license = MIT
+ makedepends = nuget
+ makedepends = git
+ makedepends = python-wheel
+ depends = python
+ depends = mono
+ provides = python-pythonnet
+ source = git+https://github.com/pythonnet/pythonnet.git
+ md5sums = SKIP
+
+pkgname = python-pythonnet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbe271835b19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Will Haines <w@willhaines.me>
+pkgname="python-pythonnet"
+pkgver=2.3.0.r110.g397b0b4
+pkgrel=1
+pkgdesc="pythonnet provides integration with the .NET Common Language Runtime (CLR)"
+arch=(any)
+url="https://pythonnet.github.io/"
+license=("MIT")
+depends=("python" "mono")
+makedepends=("nuget" "git" "python-wheel")
+provides=("python-pythonnet")
+source=("git+https://github.com/pythonnet/pythonnet.git")
+md5sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/pythonnet"
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-/./'
+}
+
+build () {
+ cd "$srcdir/pythonnet"
+ # workaround for https://github.com/pythonnet/pythonnet/issues/654
+ touch tools/geninterop/fake_libc_include/crypt.h
+ python setup.py bdist_wheel
+}
+
+package () {
+ cd "$srcdir/pythonnet"
+ pip install --no-index --find-links=./dist/ --root="$pkgdir/" --prefix="/usr" pythonnet
+}