summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMcNoggins2015-06-11 21:54:43 -0400
committerMcNoggins2015-06-11 21:54:43 -0400
commit0960916870c217a6ede474b3746e929a4b4a922c (patch)
tree9e959aa680b7cc7b6fe4aab92d95c306b5ccaa36
downloadaur-0960916870c217a6ede474b3746e929a4b4a922c.tar.gz
Initial aur4 import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--bash_completion.patch12
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7478efcb324
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pythonpy
+ pkgdesc = command line kung fu with python (python -c, with tab completion and shorthand)
+ pkgver = 0.3.8
+ pkgrel = 1
+ url = https://github.com/Russell91/pythonpy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = bash-completion: shell completion support
+ provides = python-pythonpy
+ conflicts = python2-pythonpy
+ source = https://pypi.python.org/packages/source/p/pythonpy/pythonpy-0.3.8.tar.gz
+ source = bash_completion.patch
+ sha256sums = cb4655aaf749075b5e48b0069ca7b8eaa5ba8f1eaf1b1e2304a06e67e545a943
+ sha256sums = c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69
+
+pkgname = python-pythonpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d90bd028fe7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: McNoggins <gagnon88 (at) Gmail (dot) com>
+pkgname="python-pythonpy"
+pkgver=0.3.8
+pkgrel=1
+pkgdesc="command line kung fu with python (python -c, with tab completion and shorthand)"
+arch=('any')
+url="https://github.com/Russell91/pythonpy"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('bash-completion: shell completion support')
+provides=('python-pythonpy')
+conflicts=('python2-pythonpy')
+source=("https://pypi.python.org/packages/source/p/pythonpy/pythonpy-$pkgver.tar.gz"
+ "bash_completion.patch")
+sha256sums=('cb4655aaf749075b5e48b0069ca7b8eaa5ba8f1eaf1b1e2304a06e67e545a943'
+ 'c3dfc5951d9e97dbfd5a64f63f29a7f851c24c6bba565a9594bc7614303f9f69')
+
+prepare() {
+ cd "$srcdir/pythonpy-$pkgver"
+# patch -Np1 -i ../bash_completion.patch
+}
+
+package() {
+ cd "$srcdir/pythonpy-$pkgver"
+
+ # Setup package
+ python setup.py install --root="$pkgdir"
+}
diff --git a/bash_completion.patch b/bash_completion.patch
new file mode 100644
index 000000000000..466e6ecc54ee
--- /dev/null
+++ b/bash_completion.patch
@@ -0,0 +1,12 @@
+diff -aur pythonpy-0.3.7.pristine/setup.py pythonpy-0.3.7.new/setup.py
+--- pythonpy-0.3.7.pristine/setup.py 2015-02-09 19:54:50.089070067 -0500
++++ pythonpy-0.3.7.new/setup.py 2015-02-09 19:55:04.119070198 -0500
+@@ -35,7 +35,7 @@
+ ******************************************************************************''')
+ target='bash_completion.d'
+
+-data_files = [(target, ['pythonpy/pycompletion.sh']),]
++data_files = [('/etc/bash_completion.d', ['pythonpy/pycompletion.sh']),]
+
+ py_entry = 'py%s = pythonpy.__main__:main'
+ pycompleter_entry = 'pycompleter%s = pythonpy.pycompleter:main'