summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2016-07-08 00:15:12 +0200
committerArthur Vuillard2016-07-08 00:15:12 +0200
commit43febbe0f2b57780ee175f7fccf0b8cd8771a46d (patch)
tree1eb4e74d70c0432274b72992aa1deb2b699a14b6
parentee00ce1f5536133cde6facb836619e2985bd20cb (diff)
downloadaur-43febbe0f2b57780ee175f7fccf0b8cd8771a46d.tar.gz
release 2.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--pythonz.sh4
4 files changed, 22 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e515536694c5..a58f2fb0f3b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pythonz
pkgdesc = Python installation manager supporting CPython, Stackless, PyPy and Jython
- pkgver = 1.11.0
- pkgrel = 2
+ pkgver = 2.0.1
+ pkgrel = 1
url = https://github.com/saghul/pythonz
arch = any
license = MIT
@@ -11,8 +11,10 @@ pkgbase = python-pythonz
depends = python-resumable-urlretrieve
optdepends = libtinfo: for running pypy
conflicts = python-pythonz-bd
- source = https://github.com/saghul/pythonz/archive/pythonz-1.11.0.tar.gz
- md5sums = a110750833e973adde144c292a7a3ee9
+ source = https://github.com/saghul/pythonz/archive/pythonz-2.0.1.tar.gz
+ source = pythonz.sh
+ md5sums = f421f13c6c24685d673c462e9771ada6
+ md5sums = b600ba39aed7de0e1ed2ed42ff11908c
pkgname = python-pythonz
diff --git a/.gitignore b/.gitignore
index 87b64657ff3e..2b1dd93316ea 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!PKGBUILD
!.SRCINFO
!.gitignore
+!pythonz.sh
diff --git a/PKGBUILD b/PKGBUILD
index c7914b338448..4caf15011b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname='python-pythonz'
-pkgver=1.11.0
-pkgrel=2
+pkgver=2.0.1
+pkgrel=1
pkgdesc="Python installation manager supporting CPython, Stackless, PyPy and Jython"
url="https://github.com/saghul/pythonz"
arch=('any')
@@ -8,13 +8,18 @@ license=('MIT')
depends=('python' 'python-resumable-urlretrieve')
makedepends=('python' 'python-setuptools')
conflicts=('python-pythonz-bd')
-source=("https://github.com/saghul/pythonz/archive/pythonz-$pkgver.tar.gz")
+source=(
+ "https://github.com/saghul/pythonz/archive/pythonz-$pkgver.tar.gz"
+ "pythonz.sh"
+)
optdepends=('libtinfo: for running pypy')
package() {
cd "$srcdir/pythonz-pythonz-$pkgver"
- python3 setup.py build
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ PYTHONZ_ROOT="$pkgdir/opt/pythonz" python -c "from pythonz.installer import install_pythonz ; install_pythonz()"
+ mkdir -p $pkgdir/etc/profile.d
+ install $srcdir/pythonz.sh $pkgdir/etc/profile.d
}
-md5sums=('a110750833e973adde144c292a7a3ee9')
+md5sums=('f421f13c6c24685d673c462e9771ada6'
+ 'b600ba39aed7de0e1ed2ed42ff11908c')
diff --git a/pythonz.sh b/pythonz.sh
new file mode 100644
index 000000000000..82933645c746
--- /dev/null
+++ b/pythonz.sh
@@ -0,0 +1,4 @@
+if [ -n "${BASH_VERSION:-}" -o -n "${ZSH_VERSION:-}" ] ; then
+ export PYTHONZ_ROOT=/opt/pythonz
+ source "${PYTHONZ_ROOT}/etc/bashrc"
+fi