summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2015-09-22 09:04:20 +0200
committerArthur Vuillard2015-09-22 09:04:20 +0200
commita2feef4bec6535f60be513812f3bb41c7a2c494c (patch)
treec002c12128143d92a19faf607dfdb56330e4fc8a
downloadaur-a2feef4bec6535f60be513812f3bb41c7a2c494c.tar.gz
first package for python-pythonz
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD18
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1dfcd2334dfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pythonz
+ pkgdesc = Python installation manager supporting CPython, Stackless, PyPy and Jython
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://github.com/saghul/pythonz
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/saghul/pythonz/archive/pythonz-1.10.0.tar.gz
+ md5sums = 037f3014b96494995b252c5baf3a8bf3
+
+pkgname = python-pythonz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87b64657ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d7dabec91cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname='python-pythonz'
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="Python installation manager supporting CPython, Stackless, PyPy and Jython"
+url="https://github.com/saghul/pythonz"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python' 'python-setuptools')
+source=("https://github.com/saghul/pythonz/archive/pythonz-$pkgver.tar.gz")
+
+package() {
+ cd "$srcdir/pythonz-pythonz-$pkgver"
+ python3 setup.py build
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+md5sums=('037f3014b96494995b252c5baf3a8bf3')