summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2015-09-22 09:05:47 +0200
committerArthur Vuillard2015-09-22 09:05:47 +0200
commit092a14704f298e992498949adcc0e23a45f53a4d (patch)
tree26053aca492475e8a32c50cf83cefa3e08bc69c6
downloadaur-092a14704f298e992498949adcc0e23a45f53a4d.tar.gz
first package for pythonz-bd
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6841af197681
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pythonz-bd
+ pkgdesc = Python installation manager supporting CPython, Stackless, PyPy and Jython (berdario branch)
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://github.com/berdario/pythonz
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ conflicts = python-pythonz
+ source = https://pypi.python.org/packages/source/p/pythonz-bd/pythonz-bd-1.10.1.tar.gz
+ md5sums = 8f5f94461b2547716654ab720fc2d18b
+
+pkgname = python-pythonz-bd
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..87b64657ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef1b03836672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname='python-pythonz-bd'
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Python installation manager supporting CPython, Stackless, PyPy and Jython (berdario branch)"
+url="https://github.com/berdario/pythonz"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python' 'python-setuptools')
+conflicts=('python-pythonz')
+source=("https://pypi.python.org/packages/source/p/pythonz-bd/pythonz-bd-${pkgver}.tar.gz")
+
+package() {
+ cd "$srcdir/pythonz-bd-$pkgver"
+ python3 setup.py build
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+md5sums=('8f5f94461b2547716654ab720fc2d18b')