summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-12-03 15:42:28 +0100
committerXiretza2021-12-03 15:42:28 +0100
commit17360f6e06868ba55f99f0efcdd5752211aaed0a (patch)
tree6748b6b5b191c968999cfd44bec3560150744919
downloadaur-17360f6e06868ba55f99f0efcdd5752211aaed0a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a844118acacd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pytooling
+ pkgdesc = A powerful collection of arbitrary useful classes, decorators, meta-classes and exceptions
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/pyTooling/pyTooling
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = python-pytooling-packaging
+ depends = python
+ source = python-pytooling-1.5.1.tar.gz::https://github.com/pyTooling/pyTooling/archive/v1.5.1.tar.gz
+ sha256sums = ed3cced832476f4e2bfa6b597ac4fde1fd0bf36a611676dd9a23f370a51497ab
+
+pkgname = python-pytooling
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85f5b15e0f40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_pkgname='pyTooling'
+pkgname=python-${_pkgname,,}
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="A powerful collection of arbitrary useful classes, decorators, meta-classes and exceptions"
+arch=(any)
+url="https://github.com/pyTooling/$_pkgname"
+license=('Apache')
+depends=('python')
+makedepends=('python-setuptools' 'python-pytooling-packaging')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('ed3cced832476f4e2bfa6b597ac4fde1fd0bf36a611676dd9a23f370a51497ab')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+check(){
+ cd "$_pkgname-$pkgver"
+ pytest tests/
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}