summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-10-09 09:50:20 +0200
committerMartino Pilia2018-10-09 09:50:20 +0200
commit70481faf49d383bcf671cf2123ef6012a9b10a90 (patch)
tree8ae4c72b5126a628602d219a61fb9f8f388520ae
downloadaur-70481faf49d383bcf671cf2123ef6012a9b10a90.tar.gz
package submission
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8b702a4c5a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pytorch-ignite-git
+ pkgdesc = High-level library to help with training neural networks in PyTorch
+ pkgver = 0.1.0.r39.g9e9d9b9
+ pkgrel = 1
+ url = https://pytorch.org/ignite
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-pytorch
+ source = git+https://github.com/pytorch/ignite.git
+ sha256sums = SKIP
+
+pkgname = python-pytorch-ignite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4fbb29512df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_pkgname=ignite
+pkgname=python-pytorch-ignite-git
+pkgver=0.1.0.r39.g9e9d9b9
+pkgrel=1
+pkgdesc="High-level library to help with training neural networks in PyTorch"
+arch=('any')
+url="https://pytorch.org/ignite"
+license=('BSD')
+depends=('python-pytorch')
+makedepends=('python-setuptools')
+source=("git+https://github.com/pytorch/ignite.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | \
+ sed 's/^v//;s/_/./;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m644 ${srcdir}/$_pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --optimize=1 --root=$pkgdir
+}