summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2022-03-24 14:21:01 +0100
committerPhilip Goto2022-03-24 14:21:01 +0100
commit3543b87360b11bb604f74c4ac3612e4bcdd33407 (patch)
tree5de3017b30712a45a23e266351266c3eb6848cf5
downloadaur-3543b87360b11bb604f74c4ac3612e4bcdd33407.tar.gz
Initialize
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..266bafbc9a3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pytorch-influence-functions
+ pkgdesc = PyTorch reimplementation of Influence Functions
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/nimarb/pytorch_influence_functions
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-pytorch
+ source = https://files.pythonhosted.org/packages/source/p/pytorch_influence_functions/pytorch_influence_functions-0.1.1.tar.gz
+ b2sums = 1583d8153f16ed204b68fb9b57827c5d57300185fb318f9f7216d37ddf3cc287e24c330282123c959e1c3282753b2199751372605b82d3bc19f22444faa598e5
+
+pkgname = python-pytorch-influence-functions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6190dbf5a3c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+_pkgname=pytorch_influence_functions
+pkgname=python-pytorch-influence-functions
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='PyTorch reimplementation of Influence Functions'
+arch=(any)
+url='https://github.com/nimarb/pytorch_influence_functions'
+license=(GPL)
+depends=(python-pytorch)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+b2sums=('1583d8153f16ed204b68fb9b57827c5d57300185fb318f9f7216d37ddf3cc287e24c330282123c959e1c3282753b2199751372605b82d3bc19f22444faa598e5')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ # install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}