summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-01-28 16:04:13 -0500
committeracxz2022-01-28 16:04:13 -0500
commita5debecd795eb4104ea2311d9f173247bd103a01 (patch)
tree9685a8652ca06a63dfcf214e680e8bf6060d28ac
parent72aa80bb7e01bc98b45f002050a7b325616de7cf (diff)
downloadaur-a5debecd795eb4104ea2311d9f173247bd103a01.tar.gz
updpkg 1.10.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e766b2d81314..dd1a9009f42c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pytorch-rocm
pkgdesc = Tensors and Dynamic neural networks in Python with strong GPU acceleration
- pkgver = 1.10.0
+ pkgver = 1.10.2
pkgrel = 1
url = https://pytorch.org
arch = x86_64
@@ -34,7 +34,7 @@ pkgbase = python-pytorch-rocm
depends = onednn
depends = intel-mkl
depends = python-typing_extensions
- source = pytorch-1.10.0::git+https://github.com/pytorch/pytorch.git#tag=v1.10.0
+ source = pytorch-1.10.2::git+https://github.com/pytorch/pytorch.git#tag=v1.10.2
source = python-pytorch-rocm-ios-cmake::git+https://github.com/Yangqing/ios-cmake.git
source = python-pytorch-rocm-pthreadpool::git+https://github.com/Maratyszcza/pthreadpool.git
source = python-pytorch-rocm-FP16::git+https://github.com/Maratyszcza/FP16.git
diff --git a/PKGBUILD b/PKGBUILD
index 05f1c7cdbe28..83d3f6f64ffe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=python-pytorch-rocm
_pkgname="pytorch"
-pkgver=1.10.0
-_pkgver=1.10.0
+pkgver=1.10.2
+_pkgver=1.10.2
pkgrel=1
_pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
pkgdesc="${_pkgdesc}"
@@ -247,8 +247,10 @@ build() {
python setup.py build --cmake-only
sed -E -i 's#opt/rocm/hip/lib/libamdhip64\.so\.[0-9.]+-#opt/rocm/hip/lib/libamdhip64.so#' build/build.ninja
- # same horrible hack as above
- python setup.py build
+ # this horrible hack is necessary because the current release
+ # ships inconsistent CMake which tries to build objects before
+ # thier dependencies, build twice when dependencies are available
+ python setup.py build || python setup.py build
}
_package() {