summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-12-23 13:18:40 -0500
committeracxz2020-12-23 13:18:40 -0500
commitc4275f35787d2211b60af7a8a8643a3f708ddbd4 (patch)
treee71374664e50b26e364c3325cdca8a0a9728ba88
parentf42f4871ceccad914695fdb3ccc981a1360be04c (diff)
downloadaur-c4275f35787d2211b60af7a8a8643a3f708ddbd4.tar.gz
revert hip version patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--fix-hip-version.patch21
3 files changed, 4 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7677ff19ecf..09e709fcf1f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytorch-rocm
pkgdesc = Tensors and Dynamic neural networks in Python with strong GPU acceleration
pkgver = 1.7.1
- pkgrel = 4
+ pkgrel = 5
url = https://pytorch.org
arch = x86_64
license = BSD
@@ -40,7 +40,6 @@ pkgbase = python-pytorch-rocm
source = nccl_version.patch
source = disable_non_x86_64.patch
source = find-hsa-runtime.patch::https://patch-diff.githubusercontent.com/raw/pytorch/pytorch/pull/45550.patch
- source = fix-hip-version.patch
sha256sums = SKIP
sha256sums = 83c81ec6a461110da6ae6182529f58100986b068c5182ca62cd53c648b4e4fb0
sha256sums = 26b1dd596f1e21a011ee18cab939924483d6c6d4d98e543bf76f5a9312d54d67
@@ -48,7 +47,6 @@ pkgbase = python-pytorch-rocm
sha256sums = e4a96887b41cbdfd4204ce5f16fcb16a23558d23126331794ab6aa30a66f2e0d
sha256sums = d3ef8491718ed7e814fe63e81df2f49862fffbea891d2babbcb464796a1bd680
sha256sums = SKIP
- sha256sums = a972c80561320e36b6c32933294b2b6c19715233e15c7976f2eb2db44c436b3b
pkgname = python-pytorch-rocm
pkgdesc = Tensors and Dynamic neural networks in Python with strong GPU acceleration (with ROCM)
diff --git a/PKGBUILD b/PKGBUILD
index 40aa3e06f21f..606e46b8af4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("python-pytorch-rocm" "python-pytorch-opt-rocm")
_pkgname="pytorch"
pkgver=1.7.1
_pkgver=1.7.1
-pkgrel=4
+pkgrel=5
pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
arch=('x86_64')
url="https://pytorch.org"
@@ -22,16 +22,14 @@ source=("${_pkgname}-${pkgver}::git+https://github.com/pytorch/pytorch.git#tag=v
use-system-libuv2.patch
nccl_version.patch
disable_non_x86_64.patch
- "find-hsa-runtime.patch::https://patch-diff.githubusercontent.com/raw/pytorch/pytorch/pull/45550.patch"
- fix-hip-version.patch)
+ "find-hsa-runtime.patch::https://patch-diff.githubusercontent.com/raw/pytorch/pytorch/pull/45550.patch")
sha256sums=('SKIP'
'83c81ec6a461110da6ae6182529f58100986b068c5182ca62cd53c648b4e4fb0'
'26b1dd596f1e21a011ee18cab939924483d6c6d4d98e543bf76f5a9312d54d67'
'7b65c3b209fc39f92ba58a58be6d3da40799f1922910b1171ccd9209eda1f9eb'
'e4a96887b41cbdfd4204ce5f16fcb16a23558d23126331794ab6aa30a66f2e0d'
'd3ef8491718ed7e814fe63e81df2f49862fffbea891d2babbcb464796a1bd680'
- 'SKIP'
- 'a972c80561320e36b6c32933294b2b6c19715233e15c7976f2eb2db44c436b3b')
+ 'SKIP')
prepare() {
cd "${_pkgname}-${pkgver}"
@@ -54,9 +52,6 @@ prepare() {
# https://github.com/pytorch/pytorch/pull/45550
patch -Np1 -i "${srcdir}"/find-hsa-runtime.patch
-
- # patch newer HIP version patch define
- patch -Np1 -i "${srcdir}"/fix-hip-version.patch
# remove local nccl
rm -rf third_party/nccl/nccl
diff --git a/fix-hip-version.patch b/fix-hip-version.patch
deleted file mode 100644
index 44e087efa0cf..000000000000
--- a/fix-hip-version.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/third_party/eigen/Eigen/src/Core/util/ConfigureVectorization.h b/third_party/eigen/Eigen/src/Core/util/ConfigureVectorization.h
-index 68765d4b2..df2d46832 100644
---- a/third_party/eigen/Eigen/src/Core/util/ConfigureVectorization.h
-+++ b/third_party/eigen/Eigen/src/Core/util/ConfigureVectorization.h
-@@ -401,11 +401,11 @@
- #include <hip/hip_fp16.h>
-
- #define HIP_PATCH_WITH_NEW_FP16 18215
-- #if (HIP_VERSION_PATCH < HIP_PATCH_WITH_NEW_FP16)
-- #define EIGEN_HAS_OLD_HIP_FP16
-- // Old HIP implementation does not have a explicit typedef for "half2"
-- typedef __half2 half2;
-- #endif
-+// #if (HIP_VERSION_PATCH < HIP_PATCH_WITH_NEW_FP16)
-+// #define EIGEN_HAS_OLD_HIP_FP16
-+// // Old HIP implementation does not have a explicit typedef for "half2"
-+// typedef __half2 half2;
-+// #endif
-
- #endif
-