summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-08-06 08:16:47 -0400
committeracxz2020-08-06 08:16:47 -0400
commitcedbabff484121268b7c8d5da6eda5a40e8e0854 (patch)
treecbfc7bcd821d8f7d261d7ed61ee148885634c982
parent39d53f6722d0944742c48ea02b4b86dfbe748615 (diff)
downloadaur-cedbabff484121268b7c8d5da6eda5a40e8e0854.tar.gz
add patches back in
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82bead557719..32b9f4280828 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pytorch-rocm
pkgdesc = Tensors and Dynamic neural networks in Python with strong GPU acceleration
pkgver = 1.6.0
- pkgrel = 4
+ pkgrel = 5
url = https://pytorch.org
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index a22079e1ba2d..39bf535a6bfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=("python-pytorch-rocm" "python-pytorch-opt-rocm")
_pkgname="pytorch"
pkgver=1.6.0
_pkgver=1.6.0
-pkgrel=4
+pkgrel=5
pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
arch=('x86_64')
url="https://pytorch.org"
@@ -42,14 +42,14 @@ prepare() {
git submodule update --init --recursive
# https://bugs.archlinux.org/task/64981
- #patch -N torch/utils/cpp_extension.py "${srcdir}"/fix_include_system.patch
+ patch -N torch/utils/cpp_extension.py "${srcdir}"/fix_include_system.patch
# Use system libuv
- #patch -Np1 -i "${srcdir}"/use-system-libuv.patch
- #patch -Np1 -i "${srcdir}"/use-system-libuv2.patch -d third_party/tensorpipe
+ patch -Np1 -i "${srcdir}"/use-system-libuv.patch
+ patch -Np1 -i "${srcdir}"/use-system-libuv2.patch -d third_party/tensorpipe
# FindNCCL patch to export correct nccl version
- #patch -Np1 -i "${srcdir}"/nccl_version.patch
+ patch -Np1 -i "${srcdir}"/nccl_version.patch
# https://github.com/pytorch/pytorch/issues/41886
patch -Np1 -i "${srcdir}"/find-hip.patch
@@ -58,7 +58,7 @@ prepare() {
patch -Np1 -i "${srcdir}"/find-rccl.patch
# remove local nccl
- #rm -rf third_party/nccl/nccl
+ rm -rf third_party/nccl/nccl
# Apply changes needed for ROCm
python tools/amd_build/build_amd.py