summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpiernov2021-02-25 17:28:57 +0100
committerpiernov2021-02-25 17:28:57 +0100
commitc96e0c5fcc25d1ae6f3e14cf5db2e2e1e1fbbf51 (patch)
tree21a9ce5ff6a539e74716aac01877be4ebe76794a
downloadaur-c96e0c5fcc25d1ae6f3e14cf5db2e2e1e1fbbf51.tar.gz
python-pytorch3d 0.4.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6acd9ca3e9ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pytorch3d
+ pkgdesc = Provides efficient, reusable components for 3D Computer Vision research with PyTorch.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://pytorch3d.org/
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-fvcore
+ depends = python-iopath
+ source = python-pytorch3d-0.4.0.tar.gz::https://github.com/facebookresearch/pytorch3d/archive/v0.4.0.tar.gz
+ md5sums = bfc837fbbd8f0a350276b5c07d2646a7
+
+pkgname = python-pytorch3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0da57fe6fb13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: piernov <piernov@piernov.org>
+
+pkgname=python-pytorch3d
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Provides efficient, reusable components for 3D Computer Vision research with PyTorch."
+arch=('x86_64')
+url="https://pytorch3d.org/"
+license=('BSD')
+depends=('python-fvcore' 'python-iopath')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/facebookresearch/pytorch3d/archive/v$pkgver.tar.gz")
+md5sums=('bfc837fbbd8f0a350276b5c07d2646a7')
+
+build() {
+ cd "$srcdir"/pytorch3d-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pytorch3d-$pkgver
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}