summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRONTheCookie2019-04-11 11:41:15 +0300
committerRONTheCookie2019-04-11 11:41:15 +0300
commit3df0ad5d2bde36df82a907f950f06307df265403 (patch)
tree9c2226578dbfbfe4de7805dc29821fc6991426f4
downloadaur-3df0ad5d2bde36df82a907f950f06307df265403.tar.gz
Inital Commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD23
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3233a6e61c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-pytube
+ pkgdesc = A lightweight, dependency-free Python library (and command-line utility) for downloading YouTube Videos.
+ pkgver = 9.4.0
+ pkgrel = 1
+ url = https://github.com/nficano/pytube
+ arch = any
+ license = MIT
+ source = python-pytube-9.4.0.tar.gz::https://github.com/nficano/pytube/archive/v9.4.0.tar.gz
+ sha256sums = 6bcf9078c324a9f99ac134da17a1dc678ba49813bab5b1059a8b7e23acf3db63
+
+pkgname = python-pytube
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a46be03ce3b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src
+pkg
+*.tar.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c92ab2ff2e3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ron B.S <ronthecookie0101 on gmail --OR-- me AT ronthecookie DOT me >
+
+pkgname=python-pytube
+pkgver=9.4.0
+pkgrel=1
+pkgdesc="A lightweight, dependency-free Python library (and command-line utility) for downloading YouTube Videos."
+arch=('any')
+url="https://github.com/nficano/pytube"
+license=('MIT')
+deps=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/nficano/pytube/archive/v$pkgver.tar.gz")
+sha256sums=('6bcf9078c324a9f99ac134da17a1dc678ba49813bab5b1059a8b7e23acf3db63')
+
+build() {
+ cd pytube-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd pytube-$pkgver
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}