summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-03-28 17:38:18 +0300
committerPekka Ristola2023-03-28 17:39:31 +0300
commit4caebc8b228ab204ecb03eabc42abeab7acb4bec (patch)
treec194f0f6026769265b7a32a0869a2b4543075b29
parentb5e8719b9ea8f9e0adc0966ba10d89f5f45ac233 (diff)
downloadaur-4caebc8b228ab204ecb03eabc42abeab7acb4bec.tar.gz
Update to 12.1.3
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD16
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6a56b1dabfb..2e285f2e32ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-pytube
pkgdesc = A lightweight, dependency-free Python library (and command-line utility) for downloading YouTube Videos
- pkgver = 12.1.2
+ pkgver = 12.1.3
pkgrel = 1
url = https://github.com/pytube/pytube
arch = any
license = Unlicense
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/p/pytube/pytube-12.1.2.tar.gz
- sha256sums = 2d34a484f81cae106ea84e8c00871f97dcc293e8ed8c074e65abc4119f02c98f
+ source = https://files.pythonhosted.org/packages/source/p/pytube/pytube-12.1.3.tar.gz
+ sha256sums = 6a56ce9bbc03a6aaf62a1e5a54bae003c70fe2aa1c86c279037c031d59f571b3
pkgname = python-pytube
diff --git a/.gitignore b/.gitignore
index b401713fd3ff..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
-src
-pkg
-*.tar* \ No newline at end of file
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 71cb588ae0cd..5cfc50397270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
# Contributor: Tim Schumacher <timschumi@gmx.de>
# Contributor: Ron B.S <ronthecookie0101 on gmail --OR-- me AT ronthecookie DOT me >
-pkgname=python-pytube
-pkgver=12.1.2
+_name=pytube
+pkgname=python-$_name
+pkgver=12.1.3
pkgrel=1
pkgdesc="A lightweight, dependency-free Python library (and command-line utility) for downloading YouTube Videos"
-arch=('any')
+arch=(any)
url="https://github.com/pytube/pytube"
-license=('Unlicense')
-depends=('python')
-makedepends=('python-setuptools')
-_name=${pkgname#python-}
+license=(Unlicense)
+depends=(python)
+makedepends=(python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('2d34a484f81cae106ea84e8c00871f97dcc293e8ed8c074e65abc4119f02c98f')
+sha256sums=('6a56ce9bbc03a6aaf62a1e5a54bae003c70fe2aa1c86c279037c031d59f571b3')
build() {
cd pytube-$pkgver