summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRONTheCookie2019-05-26 22:10:04 +0300
committerRONTheCookie2019-05-26 22:10:04 +0300
commitb6c907337c7d99422eba6b8dcc1e863fc14da6a3 (patch)
treeb474f60fb853a6440bea858ff0de26879a0ce71b
parent088fc2d54b917d66ed2e28d9064cbd22e185a0b1 (diff)
downloadaur-b6c907337c7d99422eba6b8dcc1e863fc14da6a3.tar.gz
add update script
-rw-r--r--update.js14
1 files changed, 14 insertions, 0 deletions
diff --git a/update.js b/update.js
new file mode 100644
index 000000000000..86a2be977c6f
--- /dev/null
+++ b/update.js
@@ -0,0 +1,14 @@
+const fs = require("fs");
+fs.writeFileSync(
+ "PKGBUILD",
+ fs
+ .readFileSync("PKGBUILD")
+ .toString()
+ .replace(
+ /pkgver=.+/g,
+ "pkgver=" + process.argv[process.argv.length - 1]
+ )
+);
+
+require("child_process").execSync("makepkg --printsrcinfo > .SRCINFO");
+require("child_process").execSync("updpkgsums");