summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2017-10-28 16:18:24 +0200
committerKarol Babioch2017-10-28 16:18:24 +0200
commit75bc0d32de9098f929139ba6e323402eb9d513af (patch)
tree811fdfb1d78b95bdc0d254df5af1f05c4658fb38
downloadaur-75bc0d32de9098f929139ba6e323402eb9d513af.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac21fed7ad32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyu2f
+ pkgdesc = U2F host library for interacting with a U2F device over USB.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/google/pyu2f/
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = git+https://github.com/google/pyu2f/#tag=0.1.1
+ sha256sums = SKIP
+
+pkgname = python-pyu2f
+
+pkgname = python2-pyu2f
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1da23138fb3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+
+pkgname=('python-pyu2f' 'python2-pyu2f')
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="U2F host library for interacting with a U2F device over USB."
+arch=('any')
+url="https://github.com/google/pyu2f/"
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+#options=('!emptydirs')
+source=("git+https://github.com/google/pyu2f/#tag=$pkgver")
+sha256sums=('SKIP')
+
+package_python-pyu2f() {
+ cd "$srcdir/pyu2f"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-pyu2f() {
+ cd "$srcdir/pyu2f"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+